[SciPy-dev] ANN: SciPy 0.7.0b1 (beta release)

Adam Mercer ramercer@gmail....
Wed Nov 26 10:23:48 CST 2008


On Wed, Nov 26, 2008 at 00:04, Jarrod Millman <millman@berkeley.edu> wrote:
> I'm pleased to announce the first beta release of SciPy 0.7.0.
>
> SciPy is a package of tools for science and engineering for Python.
> It includes modules for statistics, optimization, integration, linear
> algebra, Fourier transforms, signal and image processing, ODE solvers,
> and more.
>
> This beta release comes almost one year after the 0.6.0 release and
> contains many new features, numerous bug-fixes, improved test
> coverage, and better documentation.  Please note that SciPy 0.7.0b1
> requires Python 2.4 or greater and NumPy 1.2.0 or greater.
>
> For information, please see the release notes:
> http://sourceforge.net/project/shownotes.php?group_id=27747&release_id=642769
>
> You can download the release from here:
> http://sourceforge.net/project/showfiles.php?group_id=27747&package_id=19531&release_id=642769
>
> Thank you to everybody who contributed to this release.

Just tried build on Mac OS X Leopard using MacPorts python and I'm
getting the following build error:

building 'arpack' library
compiling C sources
C compiler: /usr/bin/gcc-4.0 -fno-strict-aliasing -Wno-long-double
-no-cpp-precomp -mno-fused-madd -fno-common -dynamic -DNDEBUG -g
-fwrapv -O3 -Wall -Wstrict-prototypes

error: file 'ARPACK/FWRAPPERS/veclib_cabi_c.c' does not exist

Anyone seen this?

Cheers

Adam


More information about the Scipy-dev mailing list