[SciPy-dev] Should scipy 0.7 be compatible with 1.1 serie at all ?

Alan McIntyre alan.mcintyre@gmail....
Wed Oct 22 02:01:31 CDT 2008


On Tue, Oct 21, 2008 at 11:28 PM, David Cournapeau
<david@ar.media.kyoto-u.ac.jp> wrote:
>    When building scipy against numpy 1.2.0, there are quite a few
> deprecation warnings related to recent changes in the C API. Should we
> update the code for 1.2.0, or shall we keep backward compatibility with
> 1.1.x serie ?

There's a patch at http://scipy.org/scipy/scipy/ticket/723 to fix some
of the PyArray_* warnings.  I don't have the time or knowledge of the
Fortran side of Sci/NumPy to figure out how to avoid using the
temporary variables that Charles doesn't like, though.  ;)


More information about the Scipy-dev mailing list