[SciPy-dev] Please help!

Aric Hagberg aric.hagberg@gmail....
Fri Aug 21 11:50:13 CDT 2009


2009/8/20 Stéfan van der Walt <stefan@sun.ac.za>:
> Hi Niall
>
> 2009/8/20 Niall Moran <niall.moran@gmail.com>:
>> I am trying to find the lowest eigenvalues and eigenvectors of a
>> sparse complex matrix using
>
> I don't think anyone has done this using SciPy before. You may contact
> Aric Hagberg or Neilen Marais (who wrapped ARPACK in
> http://projects.scipy.org/scipy/ticket/231) for more clarity on the
> situation.
>

It should work for complex double.  I just ran your example code and
it executed without failure for me.  It seems like it is giving the
correct answer (d and dreal, v and vreal are the same).

It may be that you have a miscompiled ARPACK in scipy or some part of
the complex double LAPACK/BLAS that ARPACK calls?

What platform are you using? I ran this test with stock Ubuntu
versions of LAPACK and BLAS and the dev versions of scipy and numpy.

Aric

$ uname -a
Linux ll 2.6.28-15-generic #48-Ubuntu SMP Wed Jul 29 08:53:35 UTC 2009
x86_64 GNU/Linux

$ python -c "import scipy;print scipy.__version__"
0.8.0.dev5895

$ python -c "import numpy;print numpy.__version__"
1.4.0.dev7303

$ gcc -v
Using built-in specs.
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu
4.3.3-5ubuntu4'
--with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs
--enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr
--enable-shared --with-system-zlib --libexecdir=/usr/lib
--without-included-gettext --enable-threads=posix --enable-nls
--with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3
--enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc
--enable-mpfr --with-tune=generic --enable-checking=release
--build=x86_64-linux-gnu --host=x86_64-linux-gnu
--target=x86_64-linux-gnu
Thread model: posix
gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4)


More information about the Scipy-dev mailing list