[SciPy-dev] Please help!

Niall Moran niall.moran@gmail....
Mon Aug 24 07:59:43 CDT 2009


Hi I have tried rebuilding the latest versions of numpy and scipy and
the sparse complex eigen solver is now working perfeclty. I am not
sure if this is due to a fix someone applied (looked through svn
briefly but did not see anything that looked relevant) or some changes
I made to the packages installed possible the atlas ones.
The versions I built were

numpy.__version__
'1.4.0.dev7308'

 scipy.__version__
'0.8.0.dev5909'

I removed the atlas-sse2 blas and lapack library packages just leaving
the generic ones.
apt-show-versions | grep atlas
libatlas-base-dev/jaunty uptodate 3.6.0-22ubuntu2
libatlas-headers/jaunty uptodate 3.6.0-22ubuntu2
libatlas3gf-base/jaunty uptodate 3.6.0-22ubuntu2

Previously I had built my own umfpack and swig libraries. This time I
used the packaged versions from
libsuitesparse-3.2.0/jaunty uptodate 1:3.2.0-4ubuntu2
libsuitesparse-dev/jaunty uptodate 1:3.2.0-4ubuntu2
swig/jaunty uptodate 1.3.36-1ubuntu2

Commands used to build were simply

python setup.py build --fcompiler=gnu95 install

Many thanks,

Niall.


On Sun, Aug 23, 2009 at 10:07 PM, Fernando Perez<fperez.net@gmail.com> wrote:
> 2009/8/23 Aric Hagberg <aric.hagberg@gmail.com>:
>> On Sat, Aug 22, 2009 at 11:32 PM, Fernando Perez<fperez.net@gmail.com> wrote:
>>>
>>> Aric, I bet you're on Ubuntu 8.10 or prior, and  the OP is on 9.04.
>>> It does fail on 9.04:
>>
>> I am running 9.04 - but 64 bit.  So the 64 bit libraries seem to work
>> for this case.
>
> Yes, sorry: I should have clarified the problem is on 32-bit 9.04 (and
> A. Straw  confirmed that 9.10 also has it).
>
> Cheers,
>
> f
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev
>


More information about the Scipy-dev mailing list