[SciPy-dev] numpy 1.4 rc1 conflict with icc 11.1

David Cournapeau david@ar.media.kyoto-u.ac...
Thu Dec 3 22:47:23 CST 2009


Pauli Virtanen wrote:
> to, 2009-12-03 kello 13:25 -0700, Charles R Harris kirjoitti:
> [clip]
>   
>>         numpy/core/src/npymath/npy_math_private.h(414): error: a
>>         float, double or long double type must be included in the type
>>         specifier for a _Complex or _Imaginary type
>>                   complex c99_z;
>>     
>
> This should probably read "complex double" instead of "complex" -- IIRC,
> you always need the type specifier if you want to be pedantic...
>   

I must have forgotten to clean something, because I can now reproduce
the problem myself... It is fixed in both trunk and 1.4.x, and this time
I have double checked with numscons that it does work and that all tests
pass (there is one test failure related to clog).

cheers,

David



More information about the SciPy-Dev mailing list