[SciPy-dev] numpy 1.3.0 import error

Forrest Sheng Bao forrest.bao@gmail....
Sat Dec 5 12:04:37 CST 2009


Hi David,

Do you think this could be a problem that I didn't compile python using icc
as well? The python comes as default of CentOS and the numpy is compiled in
icc by me. Could that be the reason of the error?

Cheers,
Forrest

On Thu, Dec 3, 2009 at 10:56 PM, David Cournapeau <
david@ar.media.kyoto-u.ac.jp> wrote:

> Forrest Sheng Bao wrote:
> > Hi there,
> >
> > I just compiled and installed numpy 1.3.0 on my system. But when I try
> > to import numpy, I got this error:
> >
> > from numpy import *
> > Traceback (most recent call last):
> >   File "<stdin>", line 1, in ?
> >   File
> > "/home/sbao/apps/lib64/python2.4/site-packages/numpy/__init__.py",
> > line 130, in ?
> >     import add_newdocs
> >   File
> > "/home/sbao/apps/lib64/python2.4/site-packages/numpy/add_newdocs.py",
> > line 9, in ?
> >     from lib import add_newdoc
> >   File
> > "/home/sbao/apps/lib64/python2.4/site-packages/numpy/lib/__init__.py",
> > line 4, in ?
> >     from type_check import *
> >   File
> > "/home/sbao/apps/lib64/python2.4/site-packages/numpy/lib/type_check.py",
> > line 8, in ?
> >     import numpy.core.numeric as _nx
> >   File
> > "/home/sbao/apps/lib64/python2.4/site-packages/numpy/core/__init__.py",
> > line 5, in ?
> >     import multiarray
> > ImportError:
> > /home/sbao/apps/lib64/python2.4/site-packages/numpy/core/multiarray.so:
> > undefined symbol: __intel_security_cookie
> >
> > The CPU is an Intel Xeon. Any developer know what's the reason?
>
> Most likely a problem with building with icc. __intel_security_cookie is
> a canary against buffer overflow, but I cannot find much reference about
> it. Make sure neither CFLAGS nor LDFLAGS is set when you build numpy - I
> would not be surprised if this is specific to some security-related
> flags in icc. You could look which Intel library  define this symbol, by
> running nm + grep on the Intel compiler library directory.
>
> As I mentioned in your other thread, I could finally reproduce your
> error, fixed numpy sources, and 1.4.x should now be buildable. I can
> myself import numpy built with icc 11.0 on ia32.
>
> David
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20091205/7f979b62/attachment.html 


More information about the SciPy-Dev mailing list