[SciPy-dev] Suppressing of numpy __mul__, __div__ etc
Charles R Harris
Mon Dec 14 12:06:46 CST 2009
2009/12/14 Dmitrey <firstname.lastname@example.org>
> I don't think the field name '__do_not_treat_as_scalar__ ' is a good
> choice. At first, it will be unclear what it is used for, at 2nd, some users
> / classes, that certainly are not scalars with overloaded __rdiv__ etc
> sometimes will prefer numpy __div__ method to be used.
> As for me, I would prefer something like '__use_self_operators = True' or
> '__use_numpy_operations = False' or '__involve_self_overloaded_methods__ =
> I have to release FuncDesigner tomorrow (to keep my quarterly schedule) so
> please inform me ASAP which name do you finally choose.
> Thank you in advance, D.
I think it should have numpy or ndarray in the name somewhere to indicate
that it is numpy specific. Hmm <looks in thesaurus>, maybe,
My preference among those would be __deny_ndarray__.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the SciPy-Dev