[SciPy-dev] Suppressing of numpy __mul__, __div__ etc

Charles R Harris charlesr.harris@gmail....
Mon Dec 14 12:26:12 CST 2009


2009/12/14 Dmitrey <tmp50@ukr.net>

>
>
> --- Исходное сообщение ---
> От кого: Charles R Harris <charlesr.harris@gmail.com>
> Кому: SciPy Developers List <scipy-dev@scipy.org>
> Дата: 14 декабря, 20:06:46
> Тема: Re: [SciPy-dev] Suppressing of numpy __mul__, __div__ etc
>
> 2009/12/14 Dmitrey <tmp50@ukr.net>
>
> > I don't think the field name '__do_not_treat_as_scalar__ ' is a good
> > choice. At first, it will be unclear what it is used for, at 2nd, some
> users
> > / classes, that certainly are not scalars with overloaded __rdiv__ etc
> > sometimes will prefer numpy __div__ method to be used.
> > As for me, I would prefer something like '__use_self_operators = True' or
>
> > '__use_numpy_operations = False' or '__involve_self_overloaded_methods__
> =
> > True'.
> > I have to release FuncDesigner tomorrow (to keep my quarterly schedule)
> so
> > please inform me ASAP which name do you finally choose.
> > Thank you in advance, D.
> >
> >
> I think it should have numpy or ndarray in the name somewhere to indicate
> that it is numpy specific. Hmm <looks in thesaurus>, maybe,
>
> __supercede_ndarray__,
> __disallow_ndarray__,
> __deny_ndarray__,
> __reject_ndarray__,
> __refuse_ndarray__,
> __exclude_ndarray__,
> __reject_ndarray__, ...
>
> My preference among those would be __deny_ndarray__.
>
>
> But isn't the issue present with numpy matrices or scipy.sparse matrices as
> well?
> So I guess instead of ndarray another word should be used.
>

__has_precedence__
__is_prior__

 Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20091214/7f0f1197/attachment.html 


More information about the SciPy-Dev mailing list