[SciPy-dev] scipy fails with 2.6.1 on Mac OS X

Charles سمير Doutriaux doutriaux1@llnl....
Mon Jan 5 16:31:23 CST 2009


Hi,

I'm trying to build scipy on my mac 10.5
with python 2.6.1

I get the following error message:

/usr/local/bin/gfortran -Wall -Wall -undefined dynamic_lookup -bundle  
build/temp.macosx-10.3-i386-2.6/build/src.macosx-10.3-i386-2.6/build/ 
src.macosx-10.3-i386-2.6/scipy/sparse/linalg/isolve/iterative/ 
_iterativemodule.o build/temp.macosx-10.3-i386-2.6/build/ 
src.macosx-10.3-i386-2.6/fortranobject.o build/temp.macosx-10.3- 
i386-2.6/build/src.macosx-10.3-i386-2.6/scipy/sparse/linalg/isolve/ 
iterative/STOPTEST2.o build/temp.macosx-10.3-i386-2.6/build/ 
src.macosx-10.3-i386-2.6/scipy/sparse/linalg/isolve/iterative/ 
getbreak.o build/temp.macosx-10.3-i386-2.6/build/src.macosx-10.3- 
i386-2.6/scipy/sparse/linalg/isolve/iterative/BiCGREVCOM.o build/ 
temp.macosx-10.3-i386-2.6/build/src.macosx-10.3-i386-2.6/scipy/sparse/ 
linalg/isolve/iterative/BiCGSTABREVCOM.o build/temp.macosx-10.3- 
i386-2.6/build/src.macosx-10.3-i386-2.6/scipy/sparse/linalg/isolve/ 
iterative/CGREVCOM.o build/temp.macosx-10.3-i386-2.6/build/ 
src.macosx-10.3-i386-2.6/scipy/sparse/linalg/isolve/iterative/ 
CGSREVCOM.o build/temp.macosx-10.3-i386-2.6/build/src.macosx-10.3- 
i386-2.6/scipy/sparse/linalg/isolve/iterative/GMRESREVCOM.o build/ 
temp.macosx-10.3-i386-2.6/build/src.macosx-10.3-i386-2.6/scipy/sparse/ 
linalg/isolve/iterative/QMRREVCOM.o -L/usr/local/lib/gcc/i386-apple- 
darwin8.11.1/4.3.0 -Lbuild/temp.macosx-10.3-i386-2.6 -lgfortran -o  
build/lib.macosx-10.3-i386-2.6/scipy/sparse/linalg/isolve/ 
_iterative.so -Wl,-framework -Wl,Accelerate
ld warning: duplicate dylib /usr/local/lib/libgcc_s.1.dylib
building 'scipy.sparse.linalg.dsolve._zsuperlu' extension
compiling C sources
C compiler: gcc -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall - 
Wstrict-prototypes

compile options: '-DNO_ATLAS_INFO=3 -DUSE_VENDOR_BLAS=1 -I/lgm/cdat/ 
2.6.1/lib/python2.6/site-packages/numpy/core/include -I/lgm/cdat/2.6.1/ 
include/python2.6 -c'
extra options: '-msse3'
gcc: scipy/sparse/linalg/dsolve/_superluobject.c
In file included from scipy/sparse/linalg/dsolve/_superluobject.h:8,
                  from scipy/sparse/linalg/dsolve/_superluobject.c:5:
scipy/sparse/linalg/dsolve/SuperLU/SRC/scomplex.h:60: error:  
conflicting types for '_Py_c_abs'
/lgm/cdat/2.6.1/include/python2.6/complexobject.h:30: error: previous  
declaration of '_Py_c_abs' was here
In file included from scipy/sparse/linalg/dsolve/_superluobject.h:8,
                  from scipy/sparse/linalg/dsolve/_superluobject.c:5:
scipy/sparse/linalg/dsolve/SuperLU/SRC/scomplex.h:60: error:  
conflicting types for '_Py_c_abs'
/lgm/cdat/2.6.1/include/python2.6/complexobject.h:30: error: previous  
declaration of '_Py_c_abs' was here
error: Command "gcc -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall  
-Wstrict-prototypes -DNO_ATLAS_INFO=3 -DUSE_VENDOR_BLAS=1 -I/lgm/cdat/ 
2.6.1/lib/python2.6/site-packages/numpy/core/include -I/lgm/cdat/2.6.1/ 
include/python2.6 -c scipy/sparse/linalg/dsolve/_superluobject.c -o  
build/temp.macosx-10.3-i386-2.6/scipy/sparse/linalg/dsolve/ 
_superluobject.o -msse3" failed with exit status 1

I can provide you with the full scipy build log if you want.

Thanks for your help,

C.



More information about the Scipy-dev mailing list