[SciPy-dev] test errors blocking 0.7.x branch

Jarrod Millman millman@berkeley....
Tue Jan 6 19:50:57 CST 2009


I have been meaning to look into this today, but haven't had enough
time.  So I thought I would just send it to the list, in case some
else can get to this before me.  I am seeing the following errors:

======================================================================
ERROR: Tests Obrien transform
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/stats/tests/test_mstats_basic.py",
line 469, in test_obrientransform
    assert_almost_equal(np.round(mstats.obrientransform(*args).T,4),
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/stats/mstats_basic.py",
line 1732, in obrientransform
    raise ValueError("Lack of convergence in obrientransform.")
ValueError: Lack of convergence in obrientransform.

======================================================================
ERROR: no_test_no_check_return (test_wx_spec.TestWxConverter)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/numpy/testing/decorators.py",
line 82, in skipper
    return f(*args, **kwargs)
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/tests/test_wx_spec.py",
line 114, in no_test_no_check_return
    mod.compile()
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/ext_tools.py",
line 365, in compile
    verbose = verbose, **kw)
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/build_tools.py",
line 272, in build_extension
    setup(name = module_name, ext_modules = [ext],verbose=verb)
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/numpy/distutils/core.py",
line 184, in setup
    return old_setup(**new_attr)
  File "/usr/lib/python2.5/distutils/core.py", line 168, in setup
    raise SystemExit, "error: " + str(msg)
CompileError: error: Command "g++ -pthread -fno-strict-aliasing
-DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC
-I/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave
-I/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/scxx
-I/home/jarrod/usr/local/lib/python2.5/site-packages/numpy/core/include
-I/usr/include/python2.5 -c
/r/d0/jarrod/src/scipy-projects/wx_return.cpp -o
/tmp/jarrod/python25_intermediate/compiler_03f32eef5dd808ceec230e3ab4055356/r/d0/jarrod/src/scipy-projects/wx_return.o"
failed with exit status 1

======================================================================
ERROR: test_var_in (test_wx_spec.TestWxConverter)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/numpy/testing/decorators.py",
line 82, in skipper
    return f(*args, **kwargs)
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/tests/test_wx_spec.py",
line 73, in test_var_in
    mod.compile()
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/ext_tools.py",
line 365, in compile
    verbose = verbose, **kw)
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/build_tools.py",
line 272, in build_extension
    setup(name = module_name, ext_modules = [ext],verbose=verb)
  File "/home/jarrod/usr/local/lib/python2.5/site-packages/numpy/distutils/core.py",
line 184, in setup
    return old_setup(**new_attr)
  File "/usr/lib/python2.5/distutils/core.py", line 168, in setup
    raise SystemExit, "error: " + str(msg)
CompileError: error: Command "g++ -pthread -fno-strict-aliasing
-DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC -fPIC
-I/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave
-I/home/jarrod/usr/local/lib/python2.5/site-packages/scipy/weave/scxx
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include
-I/home/jarrod/usr/local/lib/python2.5/site-packages/numpy/core/include
-I/usr/include/python2.5 -c
/r/d0/jarrod/src/scipy-projects/wx_var_in.cpp -o
/tmp/jarrod/python25_intermediate/compiler_03f32eef5dd808ceec230e3ab4055356/r/d0/jarrod/src/scipy-projects/wx_var_in.o
-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8
-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread
-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8
-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread" failed
with exit status 1

The last two have been around for awhile (I don't think they were
being run until the switch to nose).  They don't bother me too much,
since they are related to wx support for weave and appear to have been
broken for some time.  The first error seems a little more serious.
Does anyone have any idea how to fix them?  If not, should we just
mark them as known errors and go ahead and make the release?
Thoughts?

Thanks,
Jarrod


More information about the Scipy-dev mailing list