[SciPy-dev] removing wx-related weave code (was test errors blocking 0.7.x branch)

Gael Varoquaux gael.varoquaux@normalesup....
Thu Jan 29 05:19:54 CST 2009


On Thu, Jan 29, 2009 at 04:38:34PM +0530, Prabhu Ramachandran wrote:
> On 01/29/09 08:55, Nathan Bell wrote:
> > On Sun, Jan 25, 2009 at 12:31 PM, Prabhu Ramachandran
> > <prabhu@aero.iitb.ac.in> wrote:
> >> Unfortunately, testing this requires the use of nasty external
> >> resources.  In particular it requires that VTK be installed and that
> >> weave be told where to find the VTK headers and libraries.  In any case,
> >> I modified the paths suitably in the example corresponding to my
> >> system's VTK setup and it seems to work fine -- note that I'm using
> >> version 0.6.0 that ships with Ubuntu rather than SVN.

> > This speaks in favor of distributing the package separately from SciPy.

> For one single file (vtk_spec.py) that adds optional support for VTK and 
> does not affect anything else?  Or are you saying all of weave should be 
> separately packaged because of other reasons?

The discussion is mainly around the complete weave package, I believe.
This file is symptomatic, because it cannot be tested with the vanilla
install of scipy, but it is only a minor part of the argument.

Gaël


More information about the Scipy-dev mailing list