[SciPy-dev] binary compatibility question

Pauli Virtanen pav@iki...
Fri May 15 09:53:33 CDT 2009


Fri, 15 May 2009 10:44:28 -0400, josef.pktd kirjoitti:

> On Fri, May 15, 2009 at 10:19 AM,  <josef.pktd@gmail.com> wrote:
>> On Fri, May 15, 2009 at 9:39 AM,  <josef.pktd@gmail.com> wrote:
>>> I didn't follow the discussion of binary compatibility between
>>> different versions very closely.
>>>
>>> I compiled scipy 0.7.1 against numpy 1.3.0 and ran it in a virtualenv
>>> against numpy 1.2.1 and I get an immediate segfault when trying to run
>>> scipy.test(). I get the usual 4 failures when I run scipy with numpy
>>> 1.3.0

The segfaults are because we forgot to increment the ABI version.
There's a thread about this on the Numpy list.

[clip]
>> I build scipy 0.7.1 against numpy 1.2.1 (official installer) and I get
>> the same segfault. I get it already trying to `import scipy.stats`
>
> Just to see if it works, I tried to build scipy trunk against numpy
> 1.2.1, but this time I get a compiler error
[clip]
> So it looks like, I cannot test backports to scipy 0.7.1 against numpy
> 1.2.1

Scipy 0.8 will not be compatible with Numpy 1.2.x, and so the trunk will 
not build with Numpy 1.2.x.

If you want to test your backports to 0.7.x, I think you should anyway 
compile the 0.7.x branch, to which you are backporting the fixes, not the 
trunk from which you backport them.

-- 
Pauli Virtanen



More information about the Scipy-dev mailing list