[SciPy-dev] Build issue from svn

Charles R Harris charlesr.harris@gmail....
Wed Nov 4 19:32:16 CST 2009


On Wed, Nov 4, 2009 at 4:41 PM, Robert Layton <robertlayton@gmail.com>wrote:

> Hello all,
>
> I am having an issue building from the SVN, retrived today (revision 6078).
> I haven't had many problems building on this machine before, so I think its
> new.
> I have built the latest numpy (1.4.0.dev7685) which went fine, and did a
> sudo python setup.py install_headers after installing as well.
> I am on a Kubuntu 9.04 machine (2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25
> 00:28:35 UTC 2009 i686 GNU/Linux), with gcc 4.3.3 and python 2.6.2
>
> The error that is occuring after doing "python setup.py build" is:
> gcc: scipy/special/cephes/scipy_iv.c
> scipy/special/cephes/scipy_iv.c:76: error: expected ‘)’ before
> ‘__extension__’
> scipy/special/cephes/scipy_iv.c:76: error: expected ‘;’, ‘,’ or ‘)’ before
> ‘double’
> scipy/special/cephes/scipy_iv.c: In function ‘cephes_iv’:
> scipy/special/cephes/scipy_iv.c:127: warning: implicit declaration of
> function ‘ikv_temme’
> scipy/special/cephes/scipy_iv.c:81: warning: unused variable ‘vp’
> scipy/special/cephes/scipy_iv.c: In function ‘iv_asymptotic’:
> scipy/special/cephes/scipy_iv.c:140: warning: unused variable ‘mup’
> scipy/special/cephes/scipy_iv.c: At top level:
> scipy/special/cephes/scipy_iv.c:526: error: expected ‘)’ before
> ‘__extension__’
> scipy/special/cephes/scipy_iv.c:526: error: expected ‘;’, ‘,’ or ‘)’ before
> ‘double’
> scipy/special/cephes/scipy_iv.c:76: error: expected ‘)’ before
> ‘__extension__’
> scipy/special/cephes/scipy_iv.c:76: error: expected ‘;’, ‘,’ or ‘)’ before
> ‘double’
> scipy/special/cephes/scipy_iv.c: In function ‘cephes_iv’:
> scipy/special/cephes/scipy_iv.c:127: warning: implicit declaration of
> function ‘ikv_temme’
> scipy/special/cephes/scipy_iv.c:81: warning: unused variable ‘vp’
> scipy/special/cephes/scipy_iv.c: In function ‘iv_asymptotic’:
> scipy/special/cephes/scipy_iv.c:140: warning: unused variable ‘mup’
> scipy/special/cephes/scipy_iv.c: At top level:
> scipy/special/cephes/scipy_iv.c:526: error: expected ‘)’ before
> ‘__extension__’
> scipy/special/cephes/scipy_iv.c:526: error: expected ‘;’, ‘,’ or ‘)’ before
> ‘double’
> error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2
> -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.6
> -I/usr/local/lib/python2.6/dist-packages/numpy/core/include
> -I/usr/local/lib/python2.6/dist-packages/numpy/core/include -c
> scipy/special/cephes/scipy_iv.c -o
> build/temp.linux-i686-2.6/scipy/special/cephes/scipy_iv.o" failed with exit
> status 1
>
> The last change to this file was quite a while ago (update 5936, 6 weeks
> ago), during which time I have built scipy from SVN many times.
>
> Any thoughts?
>
>
Hmm, I don't see this on ubuntu 9.10 x86_64 and r6078.

I ran into another problem, though. The numpy installed by ubuntu needed to
be removed and reinstalled so get_info would be available. But which numpy
to remove? Turns out I had two versions of python2.6 installed, one in
/usr/lib and the other in /usr/local/lib and the latter was the right one.
Strange.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20091104/fcbc3ace/attachment-0001.html 


More information about the Scipy-dev mailing list