[SciPy-dev] scipy errors

Charles R Harris charlesr.harris@gmail....
Wed Nov 4 21:50:05 CST 2009


On Wed, Nov 4, 2009 at 8:18 PM, Charles R Harris
<charlesr.harris@gmail.com>wrote:

> I see the following test errors on ubuntu_x86_64 9.10
>
> ERROR: Check linalg works with non-aligned memory
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/usr/lib/pymodules/python2.6/nose/case.py", line 183, in runTest
>     self.test(*self.arg)
>   File
> "/usr/local/lib/python2.6/dist-packages/scipy/linalg/tests/test_decomp.py",
> line 1067, in test_aligned_mem
>     eig(z.T, overwrite_a=True)
>   File "/usr/local/lib/python2.6/dist-packages/scipy/linalg/decomp.py",
> line 158, in eig
>     geev, = get_lapack_funcs(('geev',),(a1,))
>   File "/usr/local/lib/python2.6/dist-packages/scipy/linalg/lapack.py",
> line 82, in get_lapack_funcs
>     raise ValueError("Non-aligned array cannot be passed to LAPACK without
> copying")
> ValueError: Non-aligned array cannot be passed to LAPACK without copying
>
> ======================================================================
> ERROR: test_mpmath.test_hyp2f1_real_some_points
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/usr/lib/pymodules/python2.6/nose/case.py", line 183, in runTest
>     self.test(*self.arg)
>   File
> "/usr/local/lib/python2.6/dist-packages/numpy/testing/decorators.py", line
> 143, in skipper_func
>     return f(*args, **kwargs)
>   File
> "/usr/local/lib/python2.6/dist-packages/scipy/special/tests/test_mpmath.py",
> line 83, in test_hyp2f1_real_some_points
>     dataset = [p + (float(mpmath.hyp2f1(*p)),) for p in pts]
> TypeError: float() argument must be a string or a number
>
> ======================================================================
> ERROR: test_mpmath.test_hyp2f1_real_some
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/usr/lib/pymodules/python2.6/nose/case.py", line 183, in runTest
>     self.test(*self.arg)
>   File
> "/usr/local/lib/python2.6/dist-packages/numpy/testing/decorators.py", line
> 143, in skipper_func
>     return f(*args, **kwargs)
>   File
> "/usr/local/lib/python2.6/dist-packages/scipy/special/tests/test_mpmath.py",
> line 109, in test_hyp2f1_real_some
>     except (TypeError, mpmath.libhyper.NoConvergence):
> AttributeError: 'module' object has no attribute 'NoConvergence'
>
> ----------------------------------------------------------------------
> Ran 3989 tests in 31.954s
>
> FAILED (KNOWNFAIL=7, SKIP=29, errors=3)
>
> I suspect the last failure is an mpmath version problem, and maybe the
> second also. Is anyone else seeing the other error?
>
>
Installing mpmath 0.13 cures the last two errors, Karmic Koala installs
mpmath-0.12. So I think there is an mpmath version dependency that needs to
be dealt with.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20091104/611b5b94/attachment.html 


More information about the Scipy-dev mailing list