[SciPy-dev] API mismatch woes

Pierre GM pgmdevlist@gmail....
Mon Sep 14 18:05:30 CDT 2009


On Sep 14, 2009, at 6:56 PM, Robert Kern wrote:

> On Mon, Sep 14, 2009 at 17:52, Pierre GM<pgmdevlist@gmail.com> wrote:
>> All,
>> I like to use
>> python -c "import setuptools; execfile('setup.py')" develop
>> to install numpy in a virtual environment, which simplifies testing
>> local modifications. Unfortunately, I keep running into the API
>> mismatch problem, even after getting rid of the build directory and
>> the *.pyc files. I'm sure I must be missing some simple step, but
>> which one ?
>
> What API mismatch problem? Copy-and-paste full error messages, please.
> I use "develop" all the time and do not run into this problem.


Here's only the first 10 lines :

Running from numpy source directory.
non-existing path in 'numpy/distutils': 'site.cfg'
F2PY Version 2_7384
numpy/core/code_generators/genapi.py:9: DeprecationWarning: the md5  
module is deprecated; use hashlib instead
   import md5
numpy/core/setup_common.py:81: MismatchCAPIWarning: API mismatch  
detected, the C API version numbers have to be updated. Current C api  
version is 3, with checksum 4526bc5a07e51d13a2db642715fedca5, but  
recorded checksum for C API version 3 in codegen_dir/cversions.txt is  
bf22c0d05b31625d2a7015988d61ce5a. If functions were added in the C  
API, you have to update C_API_VERSION  in numpy/core/setup_common.py.
   MismatchCAPIWarning)
blas_opt_info:






More information about the Scipy-dev mailing list