[SciPy-dev] API mismatch woes

David Cournapeau cournape@gmail....
Mon Sep 14 18:21:14 CDT 2009


On Tue, Sep 15, 2009 at 8:05 AM, Pierre GM <pgmdevlist@gmail.com> wrote:
>
> numpy/core/setup_common.py:81: MismatchCAPIWarning: API mismatch
> detected, the C API version numbers have to be updated. Current C api
> version is 3, with checksum 4526bc5a07e51d13a2db642715fedca5, but
> recorded checksum for C API version 3 in codegen_dir/cversions.txt is
> bf22c0d05b31625d2a7015988d61ce5a. If functions were added in the C
> API, you have to update C_API_VERSION  in numpy/core/setup_common.py.
>   MismatchCAPIWarning)
> blas_opt_info:

This has nothing to do with setuptools or virtualenv - it is a
remainder to update the C API version before we release 1.4.0.

David


More information about the Scipy-dev mailing list