[SciPy-dev] API mismatch woes

David Cournapeau cournape@gmail....
Mon Sep 14 20:47:22 CDT 2009


On Tue, Sep 15, 2009 at 10:39 AM, Pierre GM <pgmdevlist@gmail.com> wrote:
>
> On Sep 14, 2009, at 7:21 PM, David Cournapeau wrote:
>>> This has nothing to do with setuptools or virtualenv - it is a
>> remainder to update the C API version before we release 1.4.0.
>>
>> David
>
> David, I got that. I still fail to understand why I get the message:
> I'm supposedly working from a clean rep, but it doesn't seem to be the
> case (else I wouldn't get the message). My guess is that some old file
> is accessed, but I can't find it. Any pointer would be deeply
> appreciated.

You should get the message, since the C api version has not been
updated, and there is an actual mismatch  (the C API has been changed
quite a bit since 1.3.0, and I don't want to update the version
several times - once the version will be updated in alpha phase, ther
won't be any message anymore).

David


More information about the Scipy-dev mailing list