[SciPy-dev] API mismatch woes

Neil Martinsen-Burrell nmb@wartburg....
Mon Sep 14 21:30:00 CDT 2009


On 2009-09-14 21:23 , Pierre GM wrote:
>
> On Sep 14, 2009, at 9:47 PM, David Cournapeau wrote:
>>
>> You should get the message, since the C api version has not been
>> updated, and there is an actual mismatch  (the C API has been changed
>> quite a bit since 1.3.0, and I don't want to update the version
>> several times - once the version will be updated in alpha phase, ther
>> won't be any message anymore).
>
> David,
> Please be patient with me... Should I understand that it's normal that
> I get the message, and that it doesn't really matter at this point ?
> Sorry for the noise...

I believe that David means that it is normal to get this message at this 
point in Numpy's development cycle.  If you are still getting it in the 
1.4.0a stage, then it would be a problem.  Just my reading of David's 
work on C API versioning.

-Neil


More information about the Scipy-dev mailing list