[SciPy-Dev] request for testing: SciPy 0.7.2 RC1 + NumPy 1.4.1 RC1

josef.pktd@gmai... josef.pktd@gmai...
Mon Apr 5 23:10:42 CDT 2010


On Mon, Apr 5, 2010 at 11:38 PM, Ralf Gommers
<ralf.gommers@googlemail.com> wrote:
>
>
> On Tue, Apr 6, 2010 at 11:08 AM, Alan G Isaac <aisaac@american.edu> wrote:
>>
>> Python 2.6.5 (32bit) on Vista (64bit), no gcc.
>> Alan Isaac
>>
>> c:\Python26\lib\site-packages\scipy\spatial\__init__.py:7: RuntimeWarning:
>> numpy.dtype size changed, may indicate binary incompatibility
>>   from ckdtree import *
>> c:\Python26\lib\site-packages\scipy\spatial\__init__.py:7: RuntimeWarning:
>> numpy.flatiter size changed, may indicate binary incompatibility
>>   from ckdtree import *
>> c:\Python26\lib\site-packages\scipy\linsolve\__init__.py:4:
>> DeprecationWarning: scipy.linsolve has moved to scipy.sparse.linalg.dsolve
>>   warn('scipy.linsolve has moved to scipy.sparse.linalg.dsolve',
>> DeprecationWarning)
>> c:\Python26\lib\site-packages\scipy\stats\distributions.py:27:
>> RuntimeWarning: numpy.dtype size changed, may indicate binary
>> incompatibility
>>   import vonmises_cython
>> c:\Python26\lib\site-packages\scipy\stats\distributions.py:27:
>> RuntimeWarning: numpy.flatiter size changed, may indicate binary
>> incompatibility
>>   import vonmises_cython

These are now just Warnings. My thought was that maybe the new version
of cython raises a warning when it encounters the binary size mismatch
instead of the exception that it raised before.

(I think "from scipy import stats" or "from scipy import vonmises" (in
a fresh interpreter session) should show whether the cython problem is
solved.)

Just a guess,
(I will test tomorrow on XP)

Josef

>> ..................................................................................................................................................................................................................
>
> Can you please double check that it's not picking up some left-over from
> 1.4.0 on your system? This really should have been fixed.
>
>>
>> ...............................................................................................
>> ======================================================================
>> ERROR: line-search Newton conjugate gradient optimization routine
>> ----------------------------------------------------------------------
>> Traceback (most recent call last):
>>   File
>> "c:\Python26\lib\site-packages\scipy\optimize\tests\test_optimize.py", line
>> 113, in test_ncg
>>     retall=False)
>>   File "c:\Python26\lib\site-packages\scipy\optimize\optimize.py", line
>> 1088, in fmin_ncg
>>     alphak, fc, gc, old_fval = line_search_BFGS(f,xk,pk,gfk,old_fval)
>>   File "c:\Python26\lib\site-packages\scipy\optimize\optimize.py", line
>> 591, in line_search_BFGS
>>     phi_a2 = f(*((xk+alpha2*pk,)+args))
>>   File "c:\Python26\lib\site-packages\scipy\optimize\optimize.py", line
>> 97, in function_wrapper
>>     return function(x, *args)
>>   File
>> "c:\Python26\lib\site-packages\scipy\optimize\tests\test_optimize.py", line
>> 39, in func
>>     raise RuntimeError, "too many iterations in optimization routine"
>> RuntimeError: too many iterations in optimization routine
>>
> Not sure what this is about. Anyone have an idea?
>
> Ralf
>
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev
>
>


More information about the SciPy-Dev mailing list