[SciPy-Dev] numpy 1.4.1 f2py on Snow Leopard.

Jonathan Guyer guyer@nist....
Thu Apr 29 18:52:30 CDT 2010


On Apr 29, 2010, at 12:17 PM, Charles سمير Doutriaux wrote:

> I jsut built numpy 1.4.1 on my mac (64bit only no universal)
> Now f2py fails building any fortran code... 


> meryem /svn/cdat/trunk >gfortran --version
> GNU Fortran (GCC) 4.5.0 20100107 (experimental)
> Copyright (C) 2009 Free Software Foundation, Inc.

I've recently been writing up instructions for building FiPy's prerequisites on Snow Leopard http://matforge.org/fipy/wiki/SnowLeopardSourceBuild, largely based on this blog posting: http://blog.hyperjeff.net/?p=160

There seem to be issues with gfortran 4.5.0, whereas gfortran 4.2.3 has worked for me and others.





More information about the SciPy-Dev mailing list