[SciPy-Dev] scipy.test bails with segmentation error

hannes gisxperts@web...
Fri Apr 30 01:43:39 CDT 2010


Dear List, 

I installed numpy and scipy from svn source as of yesterday (30 of
april), however get an segmentation fault in the scipy.test().. 


Running unit tests for scipy
NumPy version 1.4.1
NumPy is installed in /usr/local/lib/python2.6/dist-packages/numpy
SciPy version 0.8.0.dev6362
SciPy is installed in /usr/local/lib/python2.6/dist-packages/scipy
Python version 2.6.2 (release26-maint, Apr 19 2009, 01:58:18) [GCC
4.3.3]
nose version 0.10.4

......


..saxpy:n=3
....scopy:n=4
..scopy:n=3
.............sscal:n=4
....sswap:n=4
..sswap:n=3
.....zaxpy:n=4
..zaxpy:n=3
....zcopy:n=4
..zcopy:n=3
.............zscal:n=4
....zswap:n=4
..zswap:n=3
.......Result may be inaccurate, approximate err = 6.98199990784e-09
...Result may be inaccurate, approximate err = 1.25504040833e-10
.....................................................................................................................
......................................................................................................................
.........................................................................................................................
........................................................................................................................
..............ESSSSSSSSSSS.......Segmentation fault


Anyone can shed some light ? 


python -c 'import os,sys;print os.name,sys.platform'
        posix linux2
        uname -a
        Linux hirubu 2.6.28-18-generic #60-Ubuntu SMP Fri Mar 12
        04:26:47 UTC
        2010 x86_64 GNU/Linux
        
        hannes@hirubu:~$ gcc -v
        Using built-in specs.
        Target: x86_64-linux-gnu
        Configured with: ../src/configure -v --with-pkgversion='Ubuntu
        4.3.3-5ubuntu4'
        --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs
        --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr
        --enable-shared --with-system-zlib --libexecdir=/usr/lib
        --without-included-gettext --enable-threads=posix --enable-nls
        --with-gxx-include-dir=/usr/include/c++/4.3
        --program-suffix=-4.3
        --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc
        --enable-mpfr --with-tune=generic --enable-checking=release
        --build=x86_64-linux-gnu --host=x86_64-linux-gnu
        --target=x86_64-linux-gnu
        Thread model: posix
        gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) 
        hannes@hirubu:~$ g77 --version
        bash: g77: command not found
        hannes@hirubu:~$ 
        
        python -c 'import sys;print sys.version'
        2.6.2 (release26-maint, Apr 19 2009, 01:58:18) 
        [GCC 4.3.3]
        
        for point 5 
        
        cd scipy/Lib/linalg
        python setup_atlas_version.py build_ext --inplace --force
        python -c 'import atlas_version'
        
        i cant give any information as the scipy dir does not contain
        any
        directory lib 
        
        
        
        
        
        for
        python /usr/lib/python2.6/site-packages/numpy/distutils/system_info.py
        
        
        
        lapack_info:
          libraries lapack not found in /usr/local/lib
          FOUND:
            libraries = ['lapack']
            library_dirs = ['/usr/lib']
            language = f77
        
        lapack_opt_info:
        lapack_mkl_info:
        mkl_info:
          libraries mkl,vml,guide not found in /usr/local/lib
          libraries mkl,vml,guide not found in /usr/lib
          NOT AVAILABLE
        
          NOT AVAILABLE
        
        atlas_threads_info:
        Setting PTATLAS=ATLAS
          libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
          libraries lapack_atlas not found in /usr/local/lib
          libraries ptf77blas,ptcblas,atlas not found in /usr/lib/atlas
          libraries lapack_atlas not found in /usr/lib/atlas
          libraries ptf77blas,ptcblas,atlas not found in /usr/lib
        __main__.atlas_threads_info
          NOT AVAILABLE
        
        atlas_info:
          libraries f77blas,cblas,atlas not found in /usr/local/lib
          libraries lapack_atlas not found in /usr/local/lib
          libraries f77blas,cblas,atlas not found in /usr/lib/atlas
          libraries lapack_atlas not found in /usr/lib/atlas
        __main__.atlas_info
          FOUND:
            libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
            library_dirs = ['/usr/lib']
            language = f77
            include_dirs = ['/usr/include']
        
        /usr/local/lib/python2.6/dist-packages/numpy/distutils/command/config.py:394: DeprecationWarning: 
        +++++++++++++++++++++++++++++++++++++++++++++++++
        Usage of get_output is deprecated: please do not 
        use it anymore, and avoid configuration checks 
        involving running executable on the target machine.
        +++++++++++++++++++++++++++++++++++++++++++++++++
        
          DeprecationWarning)
        customize GnuFCompiler
        Could not locate executable g77
        Found executable /usr/bin/f77
        gnu: no Fortran 90 compiler found
        gnu: no Fortran 90 compiler found
        customize IntelFCompiler
        Could not locate executable ifort
        Could not locate executable ifc
        customize LaheyFCompiler
        Could not locate executable lf95
        customize PGroupFCompiler
        Could not locate executable pgf90
        Could not locate executable pgf77
        customize AbsoftFCompiler
        Could not locate executable f90
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        customize NAGFCompiler
        Found executable /usr/bin/f95
        customize VastFCompiler
        customize GnuFCompiler
        gnu: no Fortran 90 compiler found
        gnu: no Fortran 90 compiler found
        customize CompaqFCompiler
        Could not locate executable fort
        customize IntelItaniumFCompiler
        Could not locate executable efort
        Could not locate executable efc
        customize IntelEM64TFCompiler
        customize Gnu95FCompiler
        Found executable /usr/bin/gfortran
        customize Gnu95FCompiler
        customize Gnu95FCompiler using config
          FOUND:
            libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
            library_dirs = ['/usr/lib']
            language = f77
            define_macros = [('ATLAS_INFO', '"\\"?.?.?\\""')]
            include_dirs = ['/usr/include']
        
        wx_info:
        Found executable /usr/bin/wx-config
          FOUND:
            libraries = ['wx_baseu_xml-2.8', 'wx_baseu_net-2.8',
        'wx_baseu-2.8']
            extra_link_args = ['-pthread', '-Wl,-Bsymbolic-functions']
            define_macros = [('WX_INFO', '"\\"2.8.9\\""'),
        ('WX_VERSION_2_8_9', None), ('WX_RELEASE_2_8', None),
        ('_FILE_OFFSET_BITS', '64'), ('_LARGE_FILES', None),
        ('wxUSE_GUI', '0')]
            extra_compile_args = ['-pthread']
            include_dirs =
        ['/usr/lib/wx/include/base-unicode-release-2.8',
        '/usr/include/wx-2.8']
        
        lapack_atlas_info:
          libraries lapack_atlas,f77blas,cblas,atlas not found
        in /usr/local/lib
          libraries lapack_atlas not found in /usr/local/lib
          libraries lapack_atlas,f77blas,cblas,atlas not found
        in /usr/lib/atlas
          libraries lapack_atlas not found in /usr/lib/atlas
        __main__.lapack_atlas_info
          FOUND:
            libraries = ['lapack', 'lapack_atlas', 'f77blas', 'cblas',
        'atlas']
            library_dirs = ['/usr/lib']
            language = f77
            include_dirs = ['/usr/include']
        
        umfpack_info:
          libraries umfpack not found in /usr/local/lib
          libraries umfpack not found in /usr/lib
          NOT AVAILABLE
        
        _pkg_config_info:
        Found executable /usr/bin/pkg-config
          NOT AVAILABLE
        
        lapack_atlas_threads_info:
        Setting PTATLAS=ATLAS
          libraries lapack_atlas,ptf77blas,ptcblas,atlas not found
        in /usr/local/lib
          libraries lapack_atlas not found in /usr/local/lib
          libraries lapack_atlas,ptf77blas,ptcblas,atlas not found
        in /usr/lib/atlas
          libraries lapack_atlas not found in /usr/lib/atlas
          libraries lapack_atlas,ptf77blas,ptcblas,atlas not found
        in /usr/lib
        __main__.lapack_atlas_threads_info
          NOT AVAILABLE
        
        x11_info:
          libraries X11 not found in /usr/local/lib
          FOUND:
            libraries = ['X11']
            library_dirs = ['/usr/lib']
            include_dirs = ['/usr/include']
        
        blas_info:
          libraries blas not found in /usr/local/lib
          FOUND:
            libraries = ['blas']
            library_dirs = ['/usr/lib']
            language = f77
        
        fftw_info:
          libraries fftw3 not found in /usr/local/lib
          libraries fftw3 not found in /usr/lib
          fftw3 not found
          libraries rfftw,fftw not found in /usr/local/lib
          libraries rfftw,fftw not found in /usr/lib
          fftw2 not found
          NOT AVAILABLE
        
        f2py_info:
          FOUND:
            sources =
        ['/usr/local/lib/python2.6/dist-packages/numpy/f2py/src/fortranobject.c']
            include_dirs =
        ['/usr/local/lib/python2.6/dist-packages/numpy/f2py/src']
        
        gdk_pixbuf_xlib_2_info:
          NOT AVAILABLE
        
        dfftw_threads_info:
          libraries drfftw_threads,dfftw_threads not found
        in /usr/local/lib
          libraries drfftw_threads,dfftw_threads not found in /usr/lib
          dfftw threads not found
          NOT AVAILABLE
        
        atlas_blas_info:
          libraries f77blas,cblas,atlas not found in /usr/local/lib
          libraries f77blas,cblas,atlas not found in /usr/lib/atlas
          FOUND:
            libraries = ['f77blas', 'cblas', 'atlas']
            library_dirs = ['/usr/lib']
            language = c
            include_dirs = ['/usr/include']
        
        fftw3_info:
          libraries fftw3 not found in /usr/local/lib
          libraries fftw3 not found in /usr/lib
          fftw3 not found
          NOT AVAILABLE
        
        blas_opt_info:
        blas_mkl_info:
          libraries mkl,vml,guide not found in /usr/local/lib
          libraries mkl,vml,guide not found in /usr/lib
          NOT AVAILABLE
        
        atlas_blas_threads_info:
        Setting PTATLAS=ATLAS
          libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
          libraries ptf77blas,ptcblas,atlas not found in /usr/lib/atlas
          libraries ptf77blas,ptcblas,atlas not found in /usr/lib
          NOT AVAILABLE
        
        customize GnuFCompiler
        gnu: no Fortran 90 compiler found
        gnu: no Fortran 90 compiler found
        customize IntelFCompiler
        customize LaheyFCompiler
        customize PGroupFCompiler
        customize AbsoftFCompiler
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        absoft: no Fortran 90 compiler found
        customize NAGFCompiler
        customize VastFCompiler
        customize GnuFCompiler
        gnu: no Fortran 90 compiler found
        gnu: no Fortran 90 compiler found
        customize CompaqFCompiler
        customize IntelItaniumFCompiler
        customize IntelEM64TFCompiler
        customize Gnu95FCompiler
        customize Gnu95FCompiler
        customize Gnu95FCompiler using config
          FOUND:
            libraries = ['f77blas', 'cblas', 'atlas']
            library_dirs = ['/usr/lib']
            language = c
            define_macros = [('ATLAS_INFO', '"\\"?.?.?\\""')]
            include_dirs = ['/usr/include']
        
        sfftw_info:
          libraries srfftw,sfftw not found in /usr/local/lib
          libraries srfftw,sfftw not found in /usr/lib
          sfftw not found
          NOT AVAILABLE
        
        xft_info:
          FOUND:
            libraries = ['Xft']
            define_macros = [('XFT_INFO', '"\\"2.1.13\\""'),
        ('XFT_VERSION_2_1_13', None)]
            include_dirs = ['/usr/include/freetype2']
        
        fft_opt_info:
        fftw2_info:
          libraries rfftw,fftw not found in /usr/local/lib
          libraries rfftw,fftw not found in /usr/lib
          fftw2 not found
          NOT AVAILABLE
        
        dfftw_info:
          libraries drfftw,dfftw not found in /usr/local/lib
          libraries drfftw,dfftw not found in /usr/lib
          dfftw not found
          NOT AVAILABLE
        
        djbfft_info:
          NOT AVAILABLE
        
          NOT AVAILABLE
        
        gdk_x11_2_info:
          NOT AVAILABLE
        
        agg2_info:
          NOT AVAILABLE
        
        numarray_info:
          NOT AVAILABLE
        
        blas_src_info:
          NOT AVAILABLE
        
        fftw_threads_info:
          libraries rfftw_threads,fftw_threads not found
        in /usr/local/lib
          libraries rfftw_threads,fftw_threads not found in /usr/lib
          fftw threads not found
          NOT AVAILABLE
        
        _numpy_info:
          FOUND:
            define_macros = [('NUMERIC_VERSION', '"\\"24.2\\""'),
        ('NUMERIC', None)]
        
        gdk_info:
          NOT AVAILABLE
        
        gtkp_x11_2_info:
          NOT AVAILABLE
        
        sfftw_threads_info:
          libraries srfftw_threads,sfftw_threads not found
        in /usr/local/lib
          libraries srfftw_threads,sfftw_threads not found in /usr/lib
          sfftw threads not found
          NOT AVAILABLE
        
        boost_python_info:
          NOT AVAILABLE
        
        freetype2_info:
          FOUND:
            libraries = ['freetype']
            define_macros = [('FREETYPE2_INFO', '"\\"9.20.3\\""'),
        ('FREETYPE2_VERSION_9_20_3', None)]
            include_dirs = ['/usr/include/freetype2']
        
        gdk_2_info:
          NOT AVAILABLE
        
        lapack_src_info:
          NOT AVAILABLE
        
        gtkp_2_info:
          NOT AVAILABLE
        
        gdk_pixbuf_2_info:
          NOT AVAILABLE
        
        amd_info:
          libraries amd not found in /usr/local/lib
          libraries amd not found in /usr/lib
          NOT AVAILABLE
        
        Numeric_info:
          FOUND:
            define_macros = [('NUMERIC_VERSION', '"\\"24.2\\""'),
        ('NUMERIC', None)]
        
        numerix_info:
        numpy_info:
          FOUND:
            define_macros = [('NUMPY_VERSION', '"\\"1.4.1\\""'),
        ('NUMPY', None)]
        
          FOUND:
            define_macros = [('NUMPY_VERSION', '"\\"1.4.1\\""'),
        ('NUMPY', None)]
        





More information about the SciPy-Dev mailing list