[SciPy-Dev] SciPy 0.9.0.dev6651 test failures (segfault)

Charles R Harris charlesr.harris@gmail....
Fri Aug 27 21:10:52 CDT 2010


On Fri, Aug 27, 2010 at 8:00 PM, Gökhan Sever <gokhansever@gmail.com> wrote:

>
>
> On Fri, Aug 27, 2010 at 1:14 PM, Bruce Southey <bsouthey@gmail.com> wrote:
>
>> Hi,
>> It would be useful to know which test is involved regardless of the issue.
>> Can you please run the tests with the verbose option such as:
>> 'scipy.test(verbose=10)'?
>>
>> This may have something to do with your numpy problem so please fix that
>> up once you have identified the test (failure in linalg would confirm that).
>>
>>
>> As a reference, my Fedora 13 x64 bit system uses gfortran - 'gcc version
>> 4.4.4 20100630 (Red Hat 4.4.4-10) (GCC)'.
>>
>> Did you completely wipe the previous numpy installation especially the
>> installed numpy files in $PATH2PYTHON/site-packages/ and remove any prior
>> build directories?
>> If so, then you need to create suitable site.cfg file to ensure the
>> correct compiler is being used because something has changed in either your
>> distro or numpy install.
>>
>> Bruce
>>
>
> Hello,
>
> Following David and your suggestions I resolved NumPy and SciPy install
> problems from the source repo. SciPy tests don't give any segfaults anymore.
> From the verbose=10 run I get a long list of test execution giving:
>
> Ran 4668 tests in 105.707s
>
> FAILED (KNOWNFAIL=12, SKIP=34, failures=2)
>
> I couldn't get it write into a file with piping -> python -c 'import scipy;
> scipy.test(verbose=10)' >> scipy_test
>
>
In bash:  python -c 'import scipy; scipy.test(verbose=10)'  &> scipy_test

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20100827/6de17219/attachment.html 


More information about the SciPy-Dev mailing list