[SciPy-Dev] scipy-0.8.0 install feedback: python-2.7.1 numpy-1.5.1 MacOSX-10.5.8

Ralf Gommers ralf.gommers@googlemail....
Thu Dec 9 06:27:54 CST 2010


On Thu, Dec 9, 2010 at 4:44 AM, Sidney Elmer <paulymer@gmail.com> wrote:

> Hi,
>
> I'm not sure if this is the proper place to report bugs; if not, I
> apologize and hope that it will get passed along to the appropriate list.  I
> am using a Mac Pro Dual Quad Core Intel Xeon, 2.26 GHz (Nehalem) with Mac OS
> X 10.5.8.  I installed python2.7.1 with architecture flags -arch i386 -arch
> x86_64.  I also installed numpy1.5.1.
>

Please check that ">>> numpy.test('full')" gives you no failures.


>  I used the standard command to install scipy-0.8.0:  $ sudo python
> setup.py install (this is the 64 bit python executable).
>

You shouldn't use sudo, just "python setup.py install" works better. And
install either from svn trunk or the 0.8.x branch, 0.8.0 does not work with
Python 2.7 out of the box.


>  While building scipy.sparse.linalg I got the following errors:
>

You should use gfortran instead of g77. Get it from
http://r.research.att.com/tools/.

Cheers,
Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20101209/97a33dde/attachment.html 


More information about the SciPy-Dev mailing list