[SciPy-Dev] scipy error compiling csr_wrap under Python 2.7

Vincent Davis vincent@vincentdavis....
Thu Jul 8 11:08:11 CDT 2010


On Thu, Jul 8, 2010 at 9:34 AM, Ralf Gommers
<ralf.gommers@googlemail.com> wrote:
>
>
> On Thu, Jul 8, 2010 at 9:50 PM, Vincent Davis <vincent@vincentdavis.net>
> wrote:
>>
>> On Thu, Jul 8, 2010 at 7:40 AM, Ralf Gommers
>> <ralf.gommers@googlemail.com> wrote:
>> >
>> >
>> > On Thu, Jul 8, 2010 at 9:05 PM, Vincent Davis <vincent@vincentdavis.net>
>> > wrote:
>> >>
>> >> On Thu, Jul 8, 2010 at 5:33 AM, Ralf Gommers
>> >> <ralf.gommers@googlemail.com> wrote:
>> >> >
>> >> >
>> >> > On Wed, Jul 7, 2010 at 5:27 AM, Bruce Southey <bsouthey@gmail.com>
>> >> > wrote:
>> >> >>
>> >> >> Hi,
>> >> >> I failed to get the scipy 0.8 rc1 and SVN to build under Python2.7
>> >> >> with
>> >> >> numpy '2.0.0.dev8469' and gcc version 4.4.4 20100503 (Red Hat
>> >> >> 4.4.4-2)
>> >> >> (GCC) . But scipy does compile with Python 2.6.
>> >> >>
>> >> > If this is easy to fix on linux (and someone comes up with that fix)
>> >> > it
>> >> > makes sense to do so. On OS X the problems are more serious and it
>> >> > looks
>> >> > like they require changes to numpy.distutils first, so it's not going
>> >> > to
>> >> > work with numpy 1.4.1 in any case. So full support for 2.7 on all
>> >> > platforms
>> >> > is not going to happen for the 0.8.0 release.
>> >>
>> >> Not that I know what I am doing but I do have recent numpy and scipy
>> >> installed on oxs running py2.7. I did use numscon and installed 64bit,
>> >> I get 4 errors and 2 failures. Lots of warnings, "Warning: invalid
>> >> value encountered in absolute" not sure what those are about.
>> >>
>> > Those errors are all known, so all seems fine. How did you install
>> > Python
>> > 2.7? I see your python says it's compiled with gcc 4.2, while I remember
>> > my
>> > scipy builds picking up 4.0 by default.
>>
>> Well it was not skill or knowledge :-) pure blind trial and error but
>> it seems simple now.
>> for python 2.7 from source
>> ./configure --with-universal-archs=64-bit
>> --enable-universalsdk=/Developer/SDKs/MacOSX10.5.sdk
>> --enable-framework
>> then make, make install
>>
>> I have been taking notes so I can repeat it. More details here (numpy,
>> scipy)
>> http://vincentdavis.net/installing-python
>
> Interesting. When I try the same build command for numpy with either of the
> 2.7 binaries from python.org (both built with gcc-4.0), numscons aborts
> after failing this test:
> # We check declaration AND type because that's how distutils does it.
> if config.CheckDeclaration('PY_LONG_LONG', includes = '#include
> <Python.h>\n'):
>     st = config.CheckTypeSize('PY_LONG_LONG',
>                               includes = '#include <Python.h>\n')
>     assert not st == 0
>
> And setup.py install fails because it complains about missing x86_64
> architecture.

Just ran the first part again, seems to work for me, see full output attached.
LDFLAGS="-arch x86_64" FFLAGS="-arch x86_64" py27 setupscons.py scons
 btw I just noticed that if I copy past this from the webpage the
quotes are wrong,

MacBookPro-new-2:numpy vmd$ py27
Python 2.7rc2+ (trunk, Jun 27 2010, 21:30:09)
[GCC 4.2.1 (Apple Inc. build 5659)] on darwin
Type "help", "copyright", "credits" or "license" for more information.

Vincent


>
>>
>> By the way what are "Warning: invalid value encountered in absolute"
>> warnings I tried to find out more but didn't find much.
>> Vincent
>>
> Those are from ufuncs operating on masked arrays - can't remember why it was
> hard to fix, but it's a known (and annoying) issue.
>
> Cheers,
> Ralf
>
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev
>
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: py27_numpy_2dev_osx
Type: application/octet-stream
Size: 35270 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/scipy-dev/attachments/20100708/4d4a8f9c/attachment-0001.obj 


More information about the SciPy-Dev mailing list