[SciPy-Dev] scipy error compiling csr_wrap under Python 2.7

Vitali V vitali@hkl.hms.harvard....
Tue Jul 13 13:55:46 CDT 2010


Bruce Southey <bsouthey <at> gmail.com> writes:

> 
> Hi,
> I failed to get the scipy 0.8 rc1 and SVN to build under Python2.7 with 
> numpy '2.0.0.dev8469' and gcc version 4.4.4 20100503 (Red Hat 4.4.4-2) 
> (GCC) . But scipy does compile with Python 2.6.
> 
> building 'scipy.sparse.sparsetools._csr' extension
> compiling C++ sources
> C compiler: g++ -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv 
> -O3 -Wall -fPIC
> ....

Bruce,

I've got precisely the problem when attempting to compile Scipy under
centos-5-x86_64

I've spent 2 days already trying to figure out what the problem is...
Any ideas/clues on the solution?..

Any help is highly appreciated!

Vitali






More information about the SciPy-Dev mailing list