[SciPy-Dev] Required Python Version

David Warde-Farley dwf@cs.toronto....
Mon Jul 19 12:09:45 CDT 2010


On 2010-07-18, at 12:33 PM, David Cournapeau wrote:

> I meant that we have more 2.4 users than 3.x. It is really a
> cost/benefit analysis: the advantages of 2.5 seem rather trivial to me
> compared to losing support for quite common platforms.

I had this discussion with Fernando, Brian and Gael last year in Pasadena, and they came to the conclusion that while there may be people still running crufty versions of Python, it's dubious that the same users would be installing bleeding edge IPython... The relative difficulty in building NumPy and SciPy makes me wonder whether people on these 2.4 platforms are even building from more recent tarballs, nevermind SVN.

What's the most recent version of NumPy or SciPy that's packaged for RHEL by the vendor?

David


More information about the SciPy-Dev mailing list