[SciPy-Dev] Required Python Version

Nathaniel Smith njs@pobox....
Mon Jul 19 14:50:04 CDT 2010


On Mon, Jul 19, 2010 at 10:54 AM, David Cournapeau <cournape@gmail.com> wrote:
> Building numpy and scipy is difficult, but it is nothing compared to
> having to build pygtk/pyqt, etc... which is necessary if you build
> your own python.

I'm not longer in this position (our cluster runs Debian stable
instead of RHEL, so the release of Lenny was the magic moment for me),
but I can affirm that I've had this problem too -- installing python
is really easy, getting scipy/numpy built from source not hard at all
(I think easy_install Just Worked, even if I probably gave up
something in terms of using the fastest possible math libraries), but
the graphics toolkits start putting you in dependency hell and it's a
huge pain.

-- Nathaniel


More information about the SciPy-Dev mailing list