[SciPy-Dev] ANN: SciPy 0.8.0 beta 1

Ralf Gommers ralf.gommers@googlemail....
Mon Jun 7 20:10:58 CDT 2010


On Tue, Jun 8, 2010 at 9:03 AM, David <david@silveregg.co.jp> wrote:

> On 06/08/2010 01:56 AM, Ralf Gommers wrote:
> >
> >
> > On Mon, Jun 7, 2010 at 10:20 PM, Charles R Harris
> > <charlesr.harris@gmail.com <mailto:charlesr.harris@gmail.com>> wrote:
> >
> >
> >
> >     On Mon, Jun 7, 2010 at 5:55 AM, Ralf Gommers
> >     <ralf.gommers@googlemail.com <mailto:ralf.gommers@googlemail.com>>
> >     wrote:
> >
> >
> >
> >         On Mon, Jun 7, 2010 at 7:34 PM, Neil Crighton
> >         <neilcrighton@gmail.com <mailto:neilcrighton@gmail.com>> wrote:
> >
> >             Ralf Gommers <ralf.gommers <at> googlemail.com
> >             <http://googlemail.com>> writes:
> >
> >              >  I'm pleased to announce the first beta release of SciPy
> >              > 0.8.0.SciPy is a package of tools for science and
> engineering
> >              > for Python.It includes modules for statistics,
> optimization,
> >              > integration, linearalgebra, Fourier transforms, signal and
> >              > image processing, ODE solvers, and more.This beta release
> >             comes
> >              > almost one and a half year after the 0.7.0 release
> >             andcontains
> >              > many new features, numerous bug-fixes, improved
> testcoverage,
> >              > and better documentation.  Please note that SciPy 0.8.0b1
> >              > requires Python 2.4 or greater and NumPy 1.4.1 or greater.
> >
> >             Thanks for getting the beta out!
> >
> >             The release notes say Numpy 1.3 or greater is needed - is
> this
> >             correct? Above you say 1.4.1 is needed.
> >
> >
> >         No, 1.4.1 is needed. Notes are fixed now.
> >
> >             I think "support for
> >             Python 3 in Scipy might not yet be included in Scipy 0.8" is
> too
> >             ambiguous. Just say 0.8 will not be compatible with Python
> >             3, but
> >             we expect the next version (0.9?) to be compatible, if
> >             that's the
> >             case.
> >
> >         Reworded as:
> >         "Python 3 compatibility is planned and is currently technically
> >         feasible, since Numpy has been ported. However, since the Python
> 3
> >         compatible Numpy 2.0 has not been released yet, support for
> Python 3
> >         in Scipy is not yet included in Scipy 0.8.  SciPy 0.9, planned
> >         for fall
> >         2010, will very likely include experimental support for Python
> 3."
> >
> >
> >     Are we going to release a Numpy 1.5?
> >
> >
> > Yes. Guess I should reread such a paragraph a few times before
> committing.
> >
> > The only reason I've not made a 1.5 branch yet is I will only have time
> > for a numpy release cycle at or towards the end of this scipy release
> > cycle. Saves some backporting. If you think it'd be useful to do it now
> > please let me know.
>
> I don't think we should make the 1.5 branch now - there is a lot of
> things missing, and I would really like to put everything that is needed
> for python 3.x support in scipy in the 1.5 release.


Threads are mixing a bit, but we're talking about numpy here. I thought
numpy 3.x support was pretty much finished?


> And AFAIK, we have
> not cleaned up the branch to make it ABI compatible with 1.4.x.
>
> That should be done after making the branch right? If you remove datetime
in trunk you're just going to have to put it back later.

Cheers,
Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20100608/f66b5476/attachment.html 


More information about the SciPy-Dev mailing list