[SciPy-Dev] need to install python-dev|python-devel.

Benjamin Root ben.root@ou....
Sat Jun 12 16:19:04 CDT 2010


Vincent,

Using synaptic, you can find a package called "python-dev" and install it.
Notice that you will also need several other packages like libatlas3gf-base,
libatlas-base-dev, and libatlas-headers, build-essential, liblapack3gf,
liblapack-dev, libblas3gf, and libblas-dev.

Synpatic package manager and you should become good friends!

I hope that helps.

Ben Root


On Sat, Jun 12, 2010 at 4:08 PM, Vincent Davis <vincent@vincentdavis.net>wrote:

> The current numpy downloaded from http://github.com/cournape/numpy.git
> installed. I get an error which tells me to install
> python-dev|python-devel
> I am running ubuntu 10. which comes with py 2.6.5 installed. I was not
> sure the best way to to get python-dev installed as I am not really
> sure what it is.
>
> File "numpy/core/setup.py", line 255, in check_types
>    "Cannot compiler 'Python.h'. Perhaps you need to "\
> SystemError: Cannot compiler 'Python.h'. Perhaps you need to install
> python-dev|python-devel.
>
> Seems to me this is the same error I got when trying to install on my
> osx machine. Of course there is more.
>
> Thanks
> Vincent
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20100612/2a399d7f/attachment.html 


More information about the SciPy-Dev mailing list