[SciPy-Dev] suitesparse vs scipy

Pauli Virtanen pav@iki...
Mon Aug 29 03:36:42 CDT 2011


Sun, 28 Aug 2011 19:26:04 -0400, Jack Howarth wrote:

> I've asked this question before without any responses. What are the
> supported versions of suitesparse for use with scipy? The current scipy
> 0.9.0 release doesn't appear to be fully compatible with suitesparse
> 3.6.1 and causes testsuite failures in scipy.

Can you paste the test failures you see? 

Scipy does not use suitesparse except for the optional UMFPACK wrapper,
which many people do not use. Suitesparse is still at 3.4.0 in
Debian/Ubuntu, and I suppose newer ones have not been tested.

-- 
Pauli Virtanen



More information about the SciPy-Dev mailing list