[SciPy-Dev] improvements of optimize package

Denis Laxalde denis.laxalde@mcgill...
Mon Sep 19 09:27:49 CDT 2011


On Mon, 19 Sep 2011 08:16:35 -0600,
Charles R Harris wrote:
> On Mon, Sep 19, 2011 at 7:17 AM, Denis Laxalde <denis.laxalde@mcgill.ca>wrote:
> 
> > Charles R Harris wrote:
> > > On Fri, Sep 16, 2011 at 7:43 PM, Christoph Deil
> > > <Deil.Christoph@googlemail.com> wrote:
> > > > - Why not have all optimizers return only two things, x and
> > > > infodict? The difference to your proposal would be that "ier" and
> > > > "mesg" as well as solver-dependent extra stuff would all be in
> > > > infodict instead of having variable-length return tuples, which
> > > > make it harder to quickly switch optimizers. If it's just a dict I
> > > > can simply pprint it and as long as I don't look at items that are
> > > > not available for all solvers, I only have to change one word in
> > > > the code (the optimizer name) to switch to any other optimizer.
> > > >
> > >
> > > +1, and put x in the infodict also so you can pickle the whole thing
> > > in one go or pass it to another function to analyse the results.
> >
> > Ok. So everything in a dictionary. I guess the 'infodict' name will not
> > be suitable anymore then. Maybe 'sol'?
> >
> >
> Just to clarify, I'm suggesting a return like "x, dict", with x in two
> places.

Ok. Thanks for clarifying (I misunderstood). I'll keep the 'infodict'
name then.

-- 
Denis


More information about the SciPy-Dev mailing list