[SciPy-Dev] Cython 0.16

Robert Kern robert.kern@gmail....
Wed Apr 25 07:45:02 CDT 2012


On Wed, Apr 25, 2012 at 13:20, Warren Weckesser
<warren.weckesser@enthought.com> wrote:
> Is there currently a constraint on the version of cython that can be used in
> scipy?  If so, can we bump it up to the latest version (0.16)?  I would like
> to take advantage of the fused types in a extension module that I'm working
> on.

The current policy is to generate the C sources and check them in too
so that downstream builders don't have a dependency on Cython, only
people who are actually modifying those Cython sources. So it's just a
matter of making sure that scipy developers are on the same page. I
have no objection. I would probably make a comment at the top of the
file to specify that it requires Cython 0.16.

-- 
Robert Kern


More information about the SciPy-Dev mailing list