[SciPy-Dev] scipy.sparse and OpenMP

Sturla Molden sturla@molden...
Thu Apr 26 07:08:16 CDT 2012


With respect to OpenMP, it is worth noting that with MinGW (gcc on 
Windows) it requires an LGPL pthreads library. So it would mean we have 
to build SciPy with MSVC on Windows to avoid the LGPL licence taint.

Sturla



On 05.03.2012 11:15, Maximilian Nickel wrote:
> Hi everyone,
> I've been working with fairly large sparse matrices on a
> multiprocessor system lately and noticed that scipy.sparse is
> single-threaded. Since I needed faster computations, I've quickly
> added some OpenMP #pragma directives in scipy/sparse/sparsetools to
> the functions that I've been using in order to enable multithreading,
> what worked out nicely. I wondered if you would be interested in a
> more complete OpenMP-enabled version of scipy.sparse.setuptools. I've
> attached the patch of the quick-and-dirty changes that I made so far
> to this mail, to give you an idea.
>
> Best regards
> Max
>
>
>
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev



More information about the SciPy-Dev mailing list