[SciPy-Dev] dropping Python 2.4 and 2.5 support

Pauli Virtanen pav@iki...
Thu Dec 13 14:30:57 CST 2012


13.12.2012 22:24, Ralf Gommers kirjoitti:
> On the NumPy list a proposal was made to drop support for Python 2.4 and
> 2.5 for NumPy 1.8. For SciPy it would be good to do the same. Benefits:
> less testing, the with keyword, Cython memoryviews, etc.
> 
> I propose to just follow the decision made for NumPy for the next SciPy
> release.

Sounds like a good idea to me, 2.4 is sort of a PITA, and 2.5 makes some
things more difficult than necessary.

	Pauli




More information about the SciPy-Dev mailing list