[SciPy-Dev] installation of scipy on Mac OS X 10.7

Samuel John scipy@samueljohn...
Thu Jan 26 11:27:04 CST 2012


FYI: 
I did some work to avoid the currently present problem of building scipy with pip 
on OS X Lion because of the llvm-gcc and gfortran issue.

Here we go:
    /usr/bin/ruby -e "$(curl -fsSL https://raw.github.com/gist/323731)"
    brew install gfortran
    brew install https://raw.github.com/samueljohn/homebrew-alt/samuel/duplicates/numpy.rb
    brew install https://raw.github.com/samueljohn/homebrew-alt/samuel/other/scipy.rb

Then to install matplotlib:
    cd to your site-packages:
    pip install -v -e git+https://github.com/matplotlib/matplotlib#egg=matplotlib-dev


A pity that pip install numpy, pip install scipy and pip install matplotlib seems to be broken.

bests
 Samuel


More information about the SciPy-Dev mailing list