[SciPy-Dev] TestNorm.test_stable failure [was ANN: SciPy 0.11.0 release candidate 2]

Ralf Gommers ralf.gommers@gmail....
Sat Sep 22 04:01:20 CDT 2012


On Sat, Sep 8, 2012 at 9:38 PM, <josef.pktd@gmail.com> wrote:

>
> -------------------------
> If I just unzip the superpack instead of installing the sse3, I get
> only one failure
>
> ======================================================================
> FAIL: test_basic.TestNorm.test_stable
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File
> "E:\Josef\testing\tox\py27b\lib\site-packages\nose-1.1.2-py2.7.egg\nose\case.py",
> line 197, in runTest
>     self.test(*self.arg)
>   File
> "E:\Josef\testing\tox\py27b\lib\site-packages\scipy\linalg\tests\test_basic.py",
> line 592, in
> test_stable
>     assert_almost_equal(norm(a) - 1e4, 0.0, err_msg=msg)
>   File
> "E:\Josef\testing\tox\py27b\lib\site-packages\numpy-1.6.2-py2.7-win32.egg\numpy\testing\utils.py",
> line 468, in assert_almost_equal
>     raise AssertionError(msg)
> AssertionError:
> Arrays are not almost equal to 7 decimals
> : Result should equal either 0.0 or 0.5 (depending on implementation of
> snrm2).
>  ACTUAL: 0.4990234375
>  DESIRED: 0.0
>
> maybe some sse incompatibilities.
>

This one keeps on coming back. We fixed the test for allowing 0.0 or 0.5,
but it can also just break like this. It does so at least for some people
on OS X 10.8 and on Windows. Since the problem seems to be in ATLAS /
Accelerate, should we leave it as is or not?

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20120922/57934294/attachment.html 


More information about the SciPy-Dev mailing list