[SciPy-Dev] License compatibility SciPy -> MIT -> GPL

Matthieu Brucher matthieu.brucher@gmail....
Sun Aug 25 02:11:40 CDT 2013


Hi
Unfortunately, it is the other way around: you can put bsd code in gpl
code, but if you put gpl code into bsd code, the latter has to be
relicensed. Btw, if you put gpl code indide mit code, the same has to be
done.

Cheers
Le 25 août 2013 08:00, "Saullo Castro" <saullogiovani@gmail.com> a écrit :

> Well, we've been discussion the license combatility for the cubature
> module.
>
> From the links @Warren gave me:
> http://wiki.scipy.org/License_Compatibility
> http://matplotlib.org/devel/license.html#license-discussion
>
> it states that the MIT license is compatible with SciPy, and in the MIT
> description in Wikipedia (http://en.wikipedia.org/wiki/MIT_License) it
> states that this license is compatible with the GPL. So... is there a crack
> here where we could place a GPL software in SciPy?
>
> Thank you,
> Saullo
>
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20130825/a503d34c/attachment.html 


More information about the SciPy-Dev mailing list