[SciPy-Dev] weave for Python3.3 ?

Ralf Gommers ralf.gommers@gmail....
Wed Jan 23 17:29:32 CST 2013


On Wed, Jan 23, 2013 at 11:54 AM, Helmut Jarausch <
jarausch@igpm.rwth-aachen.de> wrote:

> On Tue, 22 Jan 2013 19:59:33 +0100, Ralf Gommers wrote:
>
> > On Tue, Jan 22, 2013 at 6:25 PM, Pauli Virtanen <pav@iki.fi> wrote:
> >
> >> 22.01.2013 14:12, Helmut Jarausch kirjoitti:
> >> > has anybody started to update weave for Python3.3?
> >> > It's not a simple 2to3 call.
> >>
> >> Nobody, as far as I know.
> >
> >
> > And if you're considering working on that: think really hard first about
> > why you wouldn't move to Cython instead.
> >
>
> Yes, I prefer Cython myself. But weave is still part of the GIT version of
> SciPy. And that's the reason why the installation of SciPy fails for
> Python3.3 since the weave parts cannot be (pre-)compiled during install.
>

Hmm, haven't heard that before. Scipy installs fine on 3.1 and 3.2 at
least. Weave preventing an install is quite different from it not working
under 3.3, and should be much easier to fix. Can you give some details on
how you're installing (build command, OS) and how it's failing for you?


> What about removing weave altogether from SciPy?
>

That's not an option, for backward compatibility reasons.

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20130124/719c1e48/attachment.html 


More information about the SciPy-Dev mailing list