[SciPy-Dev] New test errors in sparse

Blake Griffith blake.a.griffith@gmail....
Thu Jun 13 23:28:31 CDT 2013


I'm having a hard time getting things working now. When I build NumPy 1.7.1
then SciPy master I run into a bunch of problems with scipy.test(). It
looks ilke:

---------------------------------------------------------------------------
RuntimeError                              Traceback (most recent call last)
RuntimeError: module compiled against API version 8 but this version of
numpy is 7

...

FAILED (KNOWNFAIL=2, SKIP=16, errors=22)

Most of the erros seem to be import errors or related to import errors. I'm
not sure what this import error means since I rebuilt scipy after building
numpy 1.7.1.





On Thu, Jun 13, 2013 at 4:50 PM, Pauli Virtanen <pav@iki.fi> wrote:

> Hi,
>
> 14.06.2013 00:12, Blake Griffith kirjoitti:
> [clip]
> > This should help, every traceback for the type errors ends in the same
> > place:
> >
> > ...
> >
> > ======================================================================
> > ERROR: test_expm (test_base.TestLIL)
> > ----------------------------------------------------------------------
> > Traceback (most recent call last):
> [clip]
> > TypeError: unsupported operand type(s) for *: 'numpy.float64' and 'long'
>
> I suggest that you use Numpy 1.7.1 for development in the meanwhile, so
> that you can concentrate on the "meaningful" failures.
>
> There's also a failure on Python 3 from a different source in your pull
> request, I just commented on that.
>
>         Pauli
>
>
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20130613/4ad6d72a/attachment.html 


More information about the SciPy-Dev mailing list