[SciPy-Dev] running into errors in scipycentral

Surya Kasturi suryak@ieee....
Sat Mar 2 08:06:38 CST 2013


On Sat, Mar 2, 2013 at 6:10 PM, Surya Kasturi <suryak@ieee.org> wrote:

>
>
>
> On Sat, Mar 2, 2013 at 5:25 PM, Andreas Hilboll <lists@hilboll.de> wrote:
>
>> >>> > I just configured scipycentral locally. When I tried to submit a
>> test
>> >>> > link in it, I encountered an error.
>> >>> >
>> >>> > http://dpaste.com/hold/1007760/ contains details of it.
>> >>> >
>> >>> > So, can you please look into it? I don't think you guys have got
>> this
>> >>> > one! It would be great if you can help me on it..
>> >>>
>> >>> Apparently, scipycentral uses Sphinx to compile the rst markup to
>> HTML.
>> >>> It seems like you didn't set up the Sphinx suite, at least, sphinx is
>> >>> complaining about a missing config.
>> >>>
>> >>> A.
>> >>>
>> >> I do have Sphinx. I guess its unable to find ./deploy/compile/conf.py
>> > right? All I think is that there must be a bug with os.path..
>> >> Note: I am on windows
>> >
>> > Maybe it will help to see a directory listing on the deployed webserver?
>> > http://pastebin.com/ph3ReddB
>> >
>> > I seem to remember using "os.sep" everywhere, instead of hard coding the
>> > directory separator, but I might have missed one or two instances.
>> >
>> > Kevin
>>
>> Is the problem solved? Source code looks fine to me; the deploy/
>> directory should get created by the ensure_dir call.
>>
>> @Kevin: Any specific reason why you used string addition and os.sep
>> instead of os.path.join to create paths? The manual adding seems more
>> error-prone to me. But maybe this is not the problem after all ... as I
>> said I cannot test on Windows.
>>
> I spared some time to fix it this weekend (today).
> I really don't know whether its caused due to os.sep or os.path or os.dir
> ... etc things -- It was a blind guess..
>
>>
>> A.
>>
>> _______________________________________________
>> SciPy-Dev mailing list
>> SciPy-Dev@scipy.org
>> http://mail.scipy.org/mailman/listinfo/scipy-dev
>>
>
>
Hey, I just had a look at the source code, where its causing error..
Here is the piece of info I found:

In call_sphinx_to_compile(working_dir) function, (rest_comments/views.py
file)

I guess working_dir variable is going wrong! I don't know but, when I
overwritten its variable with absolute dir location of "deploy/compile" in
my system, the code passed the function successfully,

However, it again went wrong in the subsequent stages where working_dir is
involved.. (line 236)

obj = pickle.load(fhand)


I guess this is where something is malfunctioning..

Actually, as you guys are quite familiar with the code (than me . still
getting along with it slowly).. I thought sharing this info with you might
help fix the bug easily
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20130302/64431952/attachment.html 


More information about the SciPy-Dev mailing list