[SciPy-Dev] scipy build error

Martin Hofsäß m.hofsaess@gmail....
Thu Mar 21 14:28:53 CDT 2013


Don't work.

I think that my icpc version is incompatible with gcc 4.7.

I think the first solution is to go back to gcc 4.6 or to update intel compiler.



2013/3/21 Alex Leach <beamesleach@gmail.com>:
> Sorry, just one dash before 'std'. See 'man icc' for details. Also worth
> trying are '-std=c++0x' and '-std=c++11'. The latter isn't documented, but
> does seem to work nonetheless.
>
> On Thu, 21 Mar 2013 19:17:29 -0000, Martin Hofsäß <m.hofsaess@gmail.com>
> wrote:
>
>> icpc --std=gnu++0x test.cpp don't work
>>
>> 2013/3/21 Alex Leach <beamesleach@gmail.com>:
>>> On Thu, 21 Mar 2013 19:02:19 -0000, Martin Hofsäß <m.hofsaess@gmail.com>
>>> wrote:
>>>
> <snip>
>>>
>>> What version of the Intel compiler do you have installed? Have you tried
>>> compiling with the "--std=gnu++0x" compile flag?
>>>
>>> Cheers,
>>> Alex
>>> _______________________________________________
>>> SciPy-Dev mailing list
>>> SciPy-Dev@scipy.org
>>> http://mail.scipy.org/mailman/listinfo/scipy-dev
>> _______________________________________________
>> SciPy-Dev mailing list
>> SciPy-Dev@scipy.org
>> http://mail.scipy.org/mailman/listinfo/scipy-dev
>
>
> _______________________________________________
> SciPy-Dev mailing list
> SciPy-Dev@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-dev


More information about the SciPy-Dev mailing list