[SciPy-Dev] scipy build error

Alex Leach beamesleach@gmail....
Thu Mar 21 14:35:14 CDT 2013


On Thu, 21 Mar 2013 19:28:53 -0000, Martin Hofsäß <m.hofsaess@gmail.com>  
wrote:

> Don't work.
>
> I think that my icpc version is incompatible with gcc 4.7.
>
> I think the first solution is to go back to gcc 4.6 or to update intel  
> compiler.
>

Works for me, with GCC 4.7.2

$ icpc test.cpp
$ ./a.out
Hello World!

$ icpc --version
icpc (ICC) 13.1.0 20130121

I remember getting this problem last year; earlier versions of icc / icpc  
weren't compatible with the atomic keyword, but they are now.. If you  
can't get hold of a newer version of icc, then yes, you'll need to get a  
hold of GCC 4.6 headers.


More information about the SciPy-Dev mailing list