[SciPy-Dev] Fwd: [Numpy-discussion] ANN: 1.8.0b2 release.

Charles R Harris charlesr.harris@gmail....
Sun Sep 8 16:18:54 CDT 2013


On Sun, Sep 8, 2013 at 2:42 PM, Daπid <davidmenhur@gmail.com> wrote:

> On 8 September 2013 21:14, Charles R Harris <charlesr.harris@gmail.com>wrote:
>
>> It would be good if folks running OS X could try out this release and
>> report any issues on the numpy-dev mailing list. Unfortunately the files
>> still need to be installed from source as dmg files are not avalable at
>> this time.
>>
>
> Hi,
>
> I have tried on a intel Mac with Python2.7 and gcc installed with Macports
> and it builds fine. The FORTRAN compiler is gfortran. There are a bunch of
> compiling warnings and errors* (attachment log27.log), but it works fine.
> Running the tests it gets printed:
>
> .......Parameter 4 to routine DGETRF was incorrect.......
>
> but all of them pass.
>
> I did not specify which BLAS to use, and it choose Accelerate, but ATLAS
> is also installed.
>
> >>> numpy.show_config()
> atlas_threads_info:
>   NOT AVAILABLE
> blas_opt_info:
>     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
>     extra_compile_args = ['-msse3',
> '-I/System/Library/Frameworks/vecLib.framework/Headers']
>     define_macros = [('NO_ATLAS_INFO', 3)]
> atlas_blas_threads_info:
>   NOT AVAILABLE
> openblas_info:
>   NOT AVAILABLE
> lapack_opt_info:
>     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
>     extra_compile_args = ['-msse3']
>     define_macros = [('NO_ATLAS_INFO', 3)]
>
>
>
> Running SciPy (from Macports) test does raise two errors and a bunch of
> Deprecation warnings. See attachment scipy.log. The first two warnings were
> present before upgrading NumPy, but not the rest.
>
>
> Let me know if you need me to run it again, or change the configuration in
> any way.
>
>
>
> Regards,
>
> David.
>
>
> -------
> * Errors such as:
>   _configtest.c:1:20: error: endian.h: No such file or directory
>   _configtest.c:5: error: size of array ‘test_array’ is negative
>   _configtest.c:7: error: ‘Py_UNICODE_WIDE’ undeclared (first use in this
> function)
>
>
> You can ignore all the _configtest errors, they are the install program
trying to figure out what works. Thanks for the report.

Chuck

>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-dev/attachments/20130908/87377a00/attachment.html 


More information about the SciPy-Dev mailing list