[SciPy-Dev] ANN: 1.8.0b2 release.

Christian K. ckkart@hoc....
Sat Sep 14 07:15:22 CDT 2013


Am 08.09.13 16:14, schrieb Charles R Harris:
> Hi all,
>
> I'm happy to announce the second beta release of Numpy 1.8.0. This
> release should solve the Windows problems encountered in the first beta.
> Many thanks to Christolph Gohlke and Julian Taylor for their hard work
> in getting those issues settled.
>
> It would be good if folks running OS X could try out this release and
> report any issues on the numpy-dev mailing list. Unfortunately the files
> still need to be installed from source as dmg files are not avalable at
> this time.

Build works (built with latest Anaconda python) but the tests fail on my 
machine (OSX 10.8.4):

FAIL: test_mode_raw (test_linalg.TestQR)
----------------------------------------------------------------------
Traceback (most recent call last):
   File 
"/Users/ck/anaconda/lib/python2.7/site-packages/numpy/linalg/tests/test_linalg.py", 
line 798, in test_mode_raw
     old_assert_almost_equal(h, h1, decimal=8)
   File 
"/Users/ck/anaconda/lib/python2.7/site-packages/numpy/testing/utils.py", 
line 454, in assert_almost_equal
     return assert_array_almost_equal(actual, desired, decimal, err_msg)
   File 
"/Users/ck/anaconda/lib/python2.7/site-packages/numpy/testing/utils.py", 
line 811, in assert_array_almost_equal
     header=('Arrays are not almost equal to %d decimals' % decimal))
   File 
"/Users/ck/anaconda/lib/python2.7/site-packages/numpy/testing/utils.py", 
line 644, in assert_array_compare
     raise AssertionError(msg)
AssertionError:
Arrays are not almost equal to 8 decimals

(mismatch 83.3333333333%)
  x: array([[ 5.91607978, -0.61024233, -1.01707056],
        [ 7.43735744,  0.82807867, -3.21391305]])
  y: array([[-5.91607978,  0.43377175,  0.72295291],
        [-7.43735744,  0.82807867,  0.89262383]])

======================================================================
FAIL: test_linalg.test_xerbla
----------------------------------------------------------------------
Traceback (most recent call last):
   File "/Users/ck/anaconda/lib/python2.7/site-packages/nose/case.py", 
line 197, in runTest
     self.test(*self.arg)
   File 
"/Users/ck/anaconda/lib/python2.7/site-packages/numpy/testing/decorators.py", 
line 146, in skipper_func
     return f(*args, **kwargs)
   File 
"/Users/ck/anaconda/lib/python2.7/site-packages/numpy/linalg/tests/test_linalg.py", 
line 925, in test_xerbla
     assert_(False)
   File 
"/Users/ck/anaconda/lib/python2.7/site-packages/numpy/testing/utils.py", 
line 44, in assert_
     raise AssertionError(msg)
AssertionError

----------------------------------------------------------------------
Ran 5235 tests in 264.167s


In [7]: np.__config__.show()
atlas_threads_info:
   NOT AVAILABLE
blas_opt_info:
     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
     extra_compile_args = ['-msse3', 
'-I/System/Library/Frameworks/vecLib.framework/Headers']
     define_macros = [('NO_ATLAS_INFO', 3)]
atlas_blas_threads_info:
   NOT AVAILABLE
openblas_info:
   NOT AVAILABLE
lapack_opt_info:
     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
     extra_compile_args = ['-msse3']
     define_macros = [('NO_ATLAS_INFO', 3)]
atlas_info:
   NOT AVAILABLE
lapack_mkl_info:
   NOT AVAILABLE
blas_mkl_info:
   NOT AVAILABLE
atlas_blas_info:
   NOT AVAILABLE
mkl_info:
   NOT AVAILABLE

compilers:

GNU Fortran (GCC) 4.2.3
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 
5658) (LLVM build 2336.11.00)

Should I use another compiler?

Regards, Christian




More information about the SciPy-Dev mailing list