<div class="gmail_quote"><div class="gmail_quote"><div>Dear scipy-dev list,</div><div><br></div><div>Scipy is failing to build on Mountain Lion, despite my using the latest fixes on github.  I&#39;m using pip install -e git+<a href="https://github.com/scipy/scipy#egg=scipy-dev" target="_blank">https://github.com/scipy/scipy#egg=scipy-dev</a></div>


<div><br></div>

<div>The installation crashes on the line: </div><blockquote style="margin:0 0 0 40px;border:none;padding:0px"><div>/usr/bin/llvm-gcc -fno-strict-aliasing -fno-common -dynamic -arch i386 -arch x86_64 -O3 -w -pipe -march=core2 -msse4 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -Iscipy/sparse/linalg/eigen/arpack/ARPACK/SRC -I/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/include -c scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c -o build/temp.macosx-10.5-intel-2.7/scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.o&quot; failed with exit status 1</div>




</blockquote><div><br></div><div>With the error:</div><blockquote style="margin:0 0 0 40px;border:none;padding:0px"><div><div>In file included from /System/Library/Frameworks/vecLib.framework/Headers/vecLib.h:43,</div></div>




<div><div>                 from /System/Library/Frameworks/Accelerate.framework/Headers/Accelerate.h:20,</div></div><div><div>                 from scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:2:</div>




</div><div><div>/System/Library/Frameworks/vecLib.framework/Headers/vfp.h:51:23: error: immintrin.h: No such file or directory</div></div><div><div>In file included from /System/Library/Frameworks/vecLib.framework/Headers/vecLib.h:43,</div>




</div><div><div>                 from /System/Library/Frameworks/Accelerate.framework/Headers/Accelerate.h:20,</div></div><div><div>                 from scipy/sparse/linalg/eigen/arpack/ARPACK/FWRAPPERS/veclib_cabi_c.c:2:</div>




</div><div><div>/System/Library/Frameworks/vecLib.framework/Headers/vfp.h: In function ‘vceilf’:</div></div><div><div>/System/Library/Frameworks/vecLib.framework/Headers/vfp.h:53: error: incompatible types in return</div>




</div><div>...</div><div><br></div></blockquote>I can compile veclib_cabi.c.c, if I change the -msse4 compilation flag to -msse3 (or if I use clang, but this causes other errors).<div><br></div><div><div>Thus my questions are:</div>




<div><br></div><div>1) how can I change the compilations flags used by python setup.py to include -msse3 instead of -msse4?</div><div>2) why is -msse4 being selected by python setup.py in the first place?</div><div>3) is this a bug with setup.py on mountain lion, or is this a problem with my installation? </div>




<div><br></div><div>Below is the information requested by the scipy installation readme.</div><div><br></div><div>python -c &#39;from numpy.f2py.diagnose import run; run()&#39;</div><div>------</div><div><a href="http://os.name" target="_blank">os.name</a>=&#39;posix&#39;</div>




<div>------</div><div>sys.platform=&#39;darwin&#39;</div><div>------</div><div>sys.version:</div><div>2.7.2 (default, Jan 14 2012, 15:51:45) </div><div>[GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)]</div>




<div>------</div><div>sys.prefix:</div><div>/Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/..</div><div>------</div><div>sys.path=&#39;:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/site-packages/pip-1.1-py2.7.egg:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python27.zip:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/distribute-0.6.24-py2.7.egg:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.0.2-py2.7.egg:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/plat-darwin:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/plat-mac:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/plat-mac/lib-scriptpackages:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/lib-tk:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/lib-old:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/lib-dynload:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages:/Users/andalman/Documents/Code/_virtualenvs/main_projects/lib/python2.7/site-packages:/Users/andalman/.local/lib/python2.7/site-packages:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages:/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg-info&#39;</div>




<div>------</div><div>Found new numpy version &#39;1.6.2&#39; in /usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/__init__.pyc</div><div>Found f2py2e version &#39;2&#39; in /usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/f2py/f2py2e.pyc</div>




<div>Found numpy.distutils version &#39;0.4.0&#39; in &#39;/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/distutils/__init__.pyc&#39;</div><div>------</div><div>



Importing numpy.distutils.fcompiler ... ok</div>
<div>------</div><div>Checking availability of supported Fortran compilers:</div><div>Gnu95FCompiler instance properties:</div><div>  archiver        = [&#39;/usr/local/bin/gfortran&#39;, &#39;-cr&#39;]</div><div>  compile_switch  = &#39;-c&#39;</div>




<div>  compiler_f77    = [&#39;/usr/local/bin/gfortran&#39;, &#39;-Wall&#39;, &#39;-ffixed-form&#39;, &#39;-</div><div>                    fno-second-underscore&#39;, &#39;-arch&#39;, &#39;i686&#39;, &#39;-arch&#39;,</div>




<div>                    &#39;x86_64&#39;, &#39;-fPIC&#39;, &#39;-O3&#39;, &#39;-funroll-loops&#39;]</div><div>  compiler_f90    = [&#39;/usr/local/bin/gfortran&#39;, &#39;-Wall&#39;, &#39;-fno-second-</div><div>                    underscore&#39;, &#39;-arch&#39;, &#39;i686&#39;, &#39;-arch&#39;, &#39;x86_64&#39;, &#39;-fPIC&#39;,</div>




<div>                    &#39;-O3&#39;, &#39;-funroll-loops&#39;]</div><div>  compiler_fix    = [&#39;/usr/local/bin/gfortran&#39;, &#39;-Wall&#39;, &#39;-ffixed-form&#39;, &#39;-</div><div>                    fno-second-underscore&#39;, &#39;-Wall&#39;, &#39;-fno-second-underscore&#39;,</div>




<div>                    &#39;-arch&#39;, &#39;i686&#39;, &#39;-arch&#39;, &#39;x86_64&#39;, &#39;-fPIC&#39;, &#39;-O3&#39;, &#39;-</div><div>                    funroll-loops&#39;]</div><div>  libraries       = [&#39;gfortran&#39;]</div>




<div>  library_dirs    = []</div><div>  linker_exe      = [&#39;/usr/local/bin/gfortran&#39;, &#39;-Wall&#39;, &#39;-Wall&#39;]</div><div>  linker_so       = [&#39;/usr/local/bin/gfortran&#39;, &#39;-Wall&#39;, &#39;-arch&#39;, &#39;i686&#39;, &#39;-</div>




<div>                    arch&#39;, &#39;x86_64&#39;, &#39;-Wall&#39;, &#39;-undefined&#39;, &#39;dynamic_lookup&#39;,</div><div>                    &#39;-bundle&#39;]</div><div>  object_switch   = &#39;-o &#39;</div><div>




  ranlib          = [&#39;/usr/local/bin/gfortran&#39;]</div><div>  version         = LooseVersion (&#39;4.2.1&#39;)</div><div>  version_cmd     = [&#39;/usr/local/bin/gfortran&#39;, &#39;--version&#39;]</div><div>Fortran compilers found:</div>




<div>  --fcompiler=gnu95  GNU Fortran 95 compiler (4.2.1)</div><div>Compilers available for this platform, but not found:</div><div>  --fcompiler=absoft  Absoft Corp Fortran Compiler</div><div>  --fcompiler=g95     G95 Fortran Compiler</div>




<div>  --fcompiler=gnu     GNU Fortran 77 compiler</div><div>  --fcompiler=ibm     IBM XL Fortran Compiler</div><div>  --fcompiler=intel   Intel Fortran Compiler for 32-bit apps</div><div>  --fcompiler=nag     NAGWare Fortran 95 Compiler</div>




<div>  --fcompiler=pg      Portland Group Fortran Compiler</div><div>Compilers not available on this platform:</div><div>  --fcompiler=compaq    Compaq Fortran Compiler</div><div>  --fcompiler=hpux      HP Fortran 90 Compiler</div>




<div>  --fcompiler=intele    Intel Fortran Compiler for Itanium apps</div><div>  --fcompiler=intelem   Intel Fortran Compiler for 64-bit apps</div><div>  --fcompiler=intelev   Intel Visual Fortran Compiler for Itanium apps</div>




<div>  --fcompiler=intelv    Intel Visual Fortran Compiler for 32-bit apps</div><div>  --fcompiler=intelvem  Intel Visual Fortran Compiler for 64-bit apps</div><div>  --fcompiler=lahey     Lahey/Fujitsu Fortran 95 Compiler</div>




<div>  --fcompiler=mips      MIPSpro Fortran Compiler</div><div>  --fcompiler=none      Fake Fortran compiler</div><div>  --fcompiler=pathf95   PathScale Fortran Compiler</div><div>  --fcompiler=sun       Sun or Forte Fortran 95 Compiler</div>




<div>  --fcompiler=vast      Pacific-Sierra Research Fortran 90 Compiler</div><div>For compiler details, run &#39;config_fc --verbose&#39; setup command.</div><div>------</div><div>Importing numpy.distutils.cpuinfo ... ok</div>




<div>------</div><div>CPU information: CPUInfoBase__get_nbits getNCPUs is_64bit is_i386 ------</div><div>(main_projects)Aaron-Andalmans-MacBook-Pro:scipy andalman$ </div><div><br></div><div>####################################</div>




<div><br></div><div><div>ython /usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages//numpy/distutils/system_info.py</div><div>lapack_info:</div><div>  libraries lapack not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries lapack not found in /usr/local/lib</div><div>  FOUND:</div><div>    libraries = [&#39;lapack&#39;]</div><div>    library_dirs = [&#39;/usr/lib&#39;]</div><div>    language = f77</div><div><br></div><div>



lapack_opt_info:</div>
<div>  FOUND:</div><div>    extra_link_args = [&#39;-Wl,-framework&#39;, &#39;-Wl,Accelerate&#39;]</div><div>    define_macros = [(&#39;NO_ATLAS_INFO&#39;, 3)]</div><div>    extra_compile_args = [&#39;-msse3&#39;]</div><div>




<br></div><div>wx_info:</div><div>Could not locate executable wx-config</div><div>File not found: None. Cannot determine wx info.</div><div>  NOT AVAILABLE</div><div><br></div><div>lapack_atlas_info:</div><div>  libraries lapack_atlas,f77blas,cblas,atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries lapack_atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries lapack_atlas,f77blas,cblas,atlas not found in /usr/local/lib</div><div>  libraries lapack_atlas not found in /usr/local/lib</div>




<div>  libraries lapack_atlas,f77blas,cblas,atlas not found in /usr/lib</div><div>  libraries lapack_atlas not found in /usr/lib</div><div>__main__.lapack_atlas_info</div><div>  NOT AVAILABLE</div><div><br></div><div>umfpack_info:</div>




<div>  libraries umfpack not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>amd_info:</div><div>  libraries amd not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  FOUND:</div><div>    libraries = [&#39;amd&#39;]</div><div>    library_dirs = [&#39;/usr/local/lib&#39;]</div><div>    swig_opts = [&#39;-I/usr/local/include&#39;]</div><div>    define_macros = [(&#39;SCIPY_AMD_H&#39;, None)]</div>




<div>    include_dirs = [&#39;/usr/local/include&#39;]</div><div><br></div><div>  FOUND:</div><div>    libraries = [&#39;umfpack&#39;, &#39;amd&#39;]</div><div>    library_dirs = [&#39;/usr/local/lib&#39;]</div><div>    swig_opts = [&#39;-I/usr/local/include&#39;, &#39;-I/usr/local/include&#39;]</div>




<div>    define_macros = [(&#39;SCIPY_UMFPACK_H&#39;, None), (&#39;SCIPY_AMD_H&#39;, None)]</div><div>    include_dirs = [&#39;/usr/local/include&#39;]</div><div><br></div><div>_pkg_config_info:</div><div>Found executable /usr/local/bin/pkg-config</div>




<div>  NOT AVAILABLE</div><div><br></div><div>lapack_atlas_threads_info:</div><div>Setting PTATLAS=ATLAS</div><div>  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries lapack_atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /usr/local/lib</div><div>  libraries lapack_atlas not found in /usr/local/lib</div>




<div>  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /usr/lib</div><div>  libraries lapack_atlas not found in /usr/lib</div><div>__main__.lapack_atlas_threads_info</div><div>  NOT AVAILABLE</div><div><br></div>




<div>x11_info:</div><div>/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages//numpy/distutils/system_info.py:538: UserWarning: Specified path /usr/X11R6/lib64 is invalid.</div>




<div>  warnings.warn(&#39;Specified path %s is invalid.&#39; % d)</div><div>/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages//numpy/distutils/system_info.py:538: UserWarning: Specified path /usr/X11/lib64 is invalid.</div>




<div>  warnings.warn(&#39;Specified path %s is invalid.&#39; % d)</div><div>/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages//numpy/distutils/system_info.py:538: UserWarning: Specified path /usr/lib64 is invalid.</div>




<div>  warnings.warn(&#39;Specified path %s is invalid.&#39; % d)</div><div>  FOUND:</div><div>    libraries = [&#39;X11&#39;]</div><div>    library_dirs = [&#39;/usr/X11R6/lib&#39;]</div><div>    include_dirs = [&#39;/usr/X11R6/include&#39;]</div>




<div><br></div><div>blas_info:</div><div>  libraries blas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries blas not found in /usr/local/lib</div><div>  FOUND:</div><div>




    libraries = [&#39;blas&#39;]</div><div>    library_dirs = [&#39;/usr/lib&#39;]</div><div>    language = f77</div><div><br></div><div>fftw_info:</div><div>  libraries fftw3 not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries fftw3 not found in /usr/local/lib</div><div>  libraries fftw3 not found in /usr/lib</div><div>  fftw3 not found</div><div>  libraries rfftw,fftw not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries rfftw,fftw not found in /usr/local/lib</div><div>  libraries rfftw,fftw not found in /usr/lib</div><div>  fftw2 not found</div><div>  NOT AVAILABLE</div><div><br></div><div>atlas_threads_info:</div><div>



Setting PTATLAS=ATLAS</div>
<div>  libraries ptf77blas,ptcblas,atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries lapack_atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib</div><div>  libraries lapack_atlas not found in /usr/local/lib</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/lib</div><div>  libraries lapack_atlas not found in /usr/lib</div>




<div>__main__.atlas_threads_info</div><div>  NOT AVAILABLE</div><div><br></div><div>f2py_info:</div><div>  FOUND:</div><div>    sources = [&#39;/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/f2py/src/fortranobject.c&#39;]</div>




<div>    include_dirs = [&#39;/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/f2py/src&#39;]</div><div><br></div><div>gdk_pixbuf_xlib_2_info:</div><div>  NOT AVAILABLE</div>




<div><br></div><div>dfftw_threads_info:</div><div>  libraries drfftw_threads,dfftw_threads not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries drfftw_threads,dfftw_threads not found in /usr/local/lib</div>




<div>  libraries drfftw_threads,dfftw_threads not found in /usr/lib</div><div>  dfftw threads not found</div><div>  NOT AVAILABLE</div><div><br></div><div>atlas_blas_info:</div><div>  libraries f77blas,cblas,atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries f77blas,cblas,atlas not found in /usr/local/lib</div><div>  libraries f77blas,cblas,atlas not found in /usr/lib</div><div>  NOT AVAILABLE</div><div><br></div><div>fftw3_info:</div><div>  libraries fftw3 not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries fftw3 not found in /usr/local/lib</div><div>  libraries fftw3 not found in /usr/lib</div><div>  fftw3 not found</div><div>  NOT AVAILABLE</div><div><br></div><div>blas_opt_info:</div><div>  FOUND:</div><div>




    extra_link_args = [&#39;-Wl,-framework&#39;, &#39;-Wl,Accelerate&#39;]</div><div>    define_macros = [(&#39;NO_ATLAS_INFO&#39;, 3)]</div><div>    extra_compile_args = [&#39;-msse3&#39;, &#39;-I/System/Library/Frameworks/vecLib.framework/Headers&#39;]</div>




<div><br></div><div>sfftw_info:</div><div>  libraries srfftw,sfftw not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries srfftw,sfftw not found in /usr/local/lib</div><div>




  libraries srfftw,sfftw not found in /usr/lib</div><div>  sfftw not found</div><div>  NOT AVAILABLE</div><div><br></div><div>xft_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>fft_opt_info:</div><div>fftw2_info:</div>




<div>  libraries rfftw,fftw not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries rfftw,fftw not found in /usr/local/lib</div><div>  libraries rfftw,fftw not found in /usr/lib</div>




<div>  fftw2 not found</div><div>  NOT AVAILABLE</div><div><br></div><div>dfftw_info:</div><div>  libraries drfftw,dfftw not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries drfftw,dfftw not found in /usr/local/lib</div>




<div>  libraries drfftw,dfftw not found in /usr/lib</div><div>  dfftw not found</div><div>  NOT AVAILABLE</div><div><br></div><div>djbfft_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>  NOT AVAILABLE</div><div>




<br></div><div>gdk_x11_2_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>agg2_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>numarray_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>blas_src_info:</div>




<div>  NOT AVAILABLE</div><div><br></div><div>fftw_threads_info:</div><div>  libraries rfftw_threads,fftw_threads not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries rfftw_threads,fftw_threads not found in /usr/local/lib</div>




<div>  libraries rfftw_threads,fftw_threads not found in /usr/lib</div><div>  fftw threads not found</div><div>  NOT AVAILABLE</div><div><br></div><div>_numpy_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>gdk_info:</div>




<div>  NOT AVAILABLE</div><div><br></div><div>gtkp_x11_2_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>sfftw_threads_info:</div><div>  libraries srfftw_threads,sfftw_threads not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries srfftw_threads,sfftw_threads not found in /usr/local/lib</div><div>  libraries srfftw_threads,sfftw_threads not found in /usr/lib</div><div>  sfftw threads not found</div><div>  NOT AVAILABLE</div><div><br>




</div><div>boost_python_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>freetype2_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>gdk_2_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>lapack_src_info:</div>




<div>  NOT AVAILABLE</div><div><br></div><div>atlas_blas_threads_info:</div><div>Setting PTATLAS=ATLAS</div><div>  libraries ptf77blas,ptcblas,atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib</div><div>  libraries ptf77blas,ptcblas,atlas not found in /usr/lib</div><div>  NOT AVAILABLE</div><div><br></div><div>gtkp_2_info:</div><div>  NOT AVAILABLE</div>




<div><br></div><div>gdk_pixbuf_2_info:</div><div>  NOT AVAILABLE</div><div><br></div><div>blas_mkl_info:</div><div>  libraries mkl,vml,guide not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries mkl,vml,guide not found in /usr/local/lib</div><div>  libraries mkl,vml,guide not found in /usr/lib</div><div>  NOT AVAILABLE</div><div><br></div><div>atlas_info:</div><div>  libraries f77blas,cblas,atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div>




<div>  libraries lapack_atlas not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries f77blas,cblas,atlas not found in /usr/local/lib</div><div>  libraries lapack_atlas not found in /usr/local/lib</div>




<div>  libraries f77blas,cblas,atlas not found in /usr/lib</div><div>  libraries lapack_atlas not found in /usr/lib</div><div>__main__.atlas_info</div><div>  NOT AVAILABLE</div><div><br></div><div>Numeric_info:</div><div>




  NOT AVAILABLE</div><div><br></div><div>numerix_info:</div><div>numpy_info:</div><div>/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages//numpy/distutils/system_info.py:538: UserWarning: Specified path /usr/local/include/python2.7 is invalid.</div>




<div>  warnings.warn(&#39;Specified path %s is invalid.&#39; % d)</div><div>/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages//numpy/distutils/system_info.py:538: UserWarning: Specified path  is invalid.</div>




<div>  warnings.warn(&#39;Specified path %s is invalid.&#39; % d)</div><div>  FOUND:</div><div>    define_macros = [(&#39;NUMPY_VERSION&#39;, &#39;&quot;\\&quot;1.6.2\\&quot;&quot;&#39;), (&#39;NUMPY&#39;, None)]</div><div>




    include_dirs = [&#39;/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/include&#39;]</div><div><br></div><div>  FOUND:</div><div>    define_macros = [(&#39;NUMPY_VERSION&#39;, &#39;&quot;\\&quot;1.6.2\\&quot;&quot;&#39;), (&#39;NUMPY&#39;, None)]</div>




<div>    include_dirs = [&#39;/usr/local/Cellar/python/2.7.2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/include&#39;]</div><div><br></div><div>lapack_mkl_info:</div><div>mkl_info:</div>




<div>  libraries mkl,vml,guide not found in /Users/andalman/Documents/Code/_virtualenvs/main_projects/bin/../lib</div><div>  libraries mkl,vml,guide not found in /usr/local/lib</div><div>  libraries mkl,vml,guide not found in /usr/lib</div>




<div>  NOT AVAILABLE</div><div><br></div><div>  NOT AVAILABLE</div></div><div><br></div></div>
<br></div><br>
</div><br>