[Scipy-svn] r5219 - trunk/tools/win32/build_scripts/nsis_scripts

scipy-svn@scip... scipy-svn@scip...
Wed Dec 3 20:56:37 CST 2008


Author: cdavid
Date: 2008-12-03 20:56:33 -0600 (Wed, 03 Dec 2008)
New Revision: 5219

Modified:
   trunk/tools/win32/build_scripts/nsis_scripts/scipy-superinstaller.nsi.in
Log:
Support all possible arch from the command line (parsing only).

Modified: trunk/tools/win32/build_scripts/nsis_scripts/scipy-superinstaller.nsi.in
===================================================================
--- trunk/tools/win32/build_scripts/nsis_scripts/scipy-superinstaller.nsi.in	2008-12-04 02:51:06 UTC (rev 5218)
+++ trunk/tools/win32/build_scripts/nsis_scripts/scipy-superinstaller.nsi.in	2008-12-04 02:56:33 UTC (rev 5219)
@@ -124,13 +124,21 @@
 
         ${Switch} $option_arch
                 ${Case} "native"
-                DetailPrint '"arch value: $option_arch  - native install"'
+                DetailPrint '"native install (arch value: $option_arch)"'
                 ${Break}
                 ${Case} "nosse"
-                DetailPrint '"arch value: $option_arch  - no-sse install"'
+                DetailPrint '"nosse install (arch value: $option_arch)"'
                 ${Break}
+                ${Case} "sse2"
+                DetailPrint '"sse2 install (arch value: $option_arch)"'
+                ${Break}
+                ${Case} "sse3"
+                DetailPrint '"sse3 install (arch value: $option_arch)"'
+                ${Break}
                 ${Default}
-                DetailPrint '"No option_arch value - native install, do not override detection"'
+                MessageBox MB_OK "option /arch $option_arch not understood: "
+                                 "only native, nosse, sse2 and sse3 are valid."
+                Abort
                 ${Break}
         ${EndSwitch}
 



More information about the Scipy-svn mailing list