[Scipy-svn] r3935 - trunk/scipy/splinalg/dsolve

scipy-svn@scip... scipy-svn@scip...
Wed Feb 13 11:29:55 CST 2008


Author: wnbell
Date: 2008-02-13 11:29:52 -0600 (Wed, 13 Feb 2008)
New Revision: 3935

Modified:
   trunk/scipy/splinalg/dsolve/linsolve.py
Log:
fixed isUmfpack error


Modified: trunk/scipy/splinalg/dsolve/linsolve.py
===================================================================
--- trunk/scipy/splinalg/dsolve/linsolve.py	2008-02-13 08:52:06 UTC (rev 3934)
+++ trunk/scipy/splinalg/dsolve/linsolve.py	2008-02-13 17:29:52 UTC (rev 3935)
@@ -12,9 +12,9 @@
 except ImportError:
     import umfpack
     noScikit = True
-else:
-    isUmfpack = hasattr( umfpack, 'UMFPACK_OK' )
 
+isUmfpack = hasattr( umfpack, 'UMFPACK_OK' )
+
 if isUmfpack and noScikit:
     warn( 'scipy.splinalg.dsolve.umfpack will be removed,'
           ' install scikits.umfpack instead', DeprecationWarning )



More information about the Scipy-svn mailing list