[Scipy-tickets] [SciPy] #369: Windows binary 0.5.2 for Python 2.5 requires SSE2

SciPy scipy-tickets@scipy....
Wed Feb 7 13:35:46 CST 2007


#369: Windows binary 0.5.2 for Python 2.5 requires SSE2
-------------------------------+--------------------------------------------
 Reporter:  JonathanGriffitts  |       Owner:  somebody
     Type:  defect             |      Status:  new     
 Priority:  normal             |   Milestone:          
Component:  Other              |     Version:  0.5.2   
 Severity:  normal             |    Keywords:          
-------------------------------+--------------------------------------------
 I have installed SciPy 0.5.2 for Python 2.5 on several Windows computers,
 using the precompiled binary scipy-0.5.2.win32-py2.5.exe.  This works fine
 on some, but on others it crashes Python with an Illegal Instruction
 exception.  The crash is easy to find by running the test() suite or by
 attempting to make any use of scipy.integrate.quad.

 Digging into it, I see that the exception comes from _quadpack.pyd, and it
 dies at a MOVSD instruction.  MOVSD is an SSE2 instruction that is only
 implemented on the more recent CPUs from both Intel and AMD.

-- 
Ticket URL: <http://projects.scipy.org/scipy/scipy/ticket/369>
SciPy <http://www.scipy.org/>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list