[Scipy-tickets] [SciPy] #349: Compile on RHEL 4 x86_64

SciPy scipy-tickets at scipy.net
Thu Jan 18 19:34:44 CST 2007


#349: Compile on RHEL 4 x86_64
---------------------+------------------------------------------------------
 Reporter:  ckidder  |        Owner:  somebody
     Type:  defect   |       Status:  new     
 Priority:  normal   |    Milestone:          
Component:  Other    |      Version:  0.5.2   
 Severity:  normal   |   Resolution:          
 Keywords:           |  
---------------------+------------------------------------------------------
Old description:

> I was trying to compile SciPy on RHEL 4 after having sucessfully
> installed numpy.  I ran 'python setup.py install' and all went well until
> we got to this:
>
> {{{c
> ompiling Fortran sources
> Fortran f77 compiler: /usr/bin/g77 -g -Wall -fno-second-underscore -fPIC
> -O3 -funroll-loops -march=i686 -mmmx -msse2 -msse -fomit-frame-pointer
> creating build/temp.linux-x86_64-2.3
> creating build/temp.linux-x86_64-2.3/Lib
> creating build/temp.linux-x86_64-2.3/Lib/fftpack
> creating build/temp.linux-x86_64-2.3/Lib/fftpack/dfftpack
> compile options: '-c'
> g77:f77: Lib/fftpack/dfftpack/dsinqi.f
> Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
> x86-64 instruction set
> Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
> x86-64 instruction set
> Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
> x86-64 instruction set
> Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
> x86-64 instruction set
> error: Command "/usr/bin/g77 -g -Wall -fno-second-underscore -fPIC -O3
> -funroll-loops -march=i686 -mmmx -msse2 -msse -fomit-frame-pointer -c -c
> Lib/fftpack/dfftpack/dsinqi.f -o
> build/temp.linux-x86_64-2.3/Lib/fftpack/dfftpack/dsinqi.o" failed with
> exit status 1
> }}}
>

> ----------------------------
> If you know of the solution, please email me at cckidder at gmail.com

New description:

 I was trying to compile SciPy on RHEL 4 after having sucessfully installed
 numpy.  I ran 'python setup.py install' and all went well until we got to
 this:

 {{{
 compiling Fortran sources
 Fortran f77 compiler: /usr/bin/g77 -g -Wall -fno-second-underscore -fPIC
 -O3 -funroll-loops -march=i686 -mmmx -msse2 -msse -fomit-frame-pointer
 creating build/temp.linux-x86_64-2.3
 creating build/temp.linux-x86_64-2.3/Lib
 creating build/temp.linux-x86_64-2.3/Lib/fftpack
 creating build/temp.linux-x86_64-2.3/Lib/fftpack/dfftpack
 compile options: '-c'
 g77:f77: Lib/fftpack/dfftpack/dsinqi.f
 Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
 x86-64 instruction set
 Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
 x86-64 instruction set
 Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
 x86-64 instruction set
 Lib/fftpack/dfftpack/dsinqi.f:0: error: CPU you selected does not support
 x86-64 instruction set
 error: Command "/usr/bin/g77 -g -Wall -fno-second-underscore -fPIC -O3
 -funroll-loops -march=i686 -mmmx -msse2 -msse -fomit-frame-pointer -c -c
 Lib/fftpack/dfftpack/dsinqi.f -o
 build/temp.linux-x86_64-2.3/Lib/fftpack/dfftpack/dsinqi.o" failed with
 exit status 1
 }}}


 ----------------------------
 If you know of the solution, please email me at cckidder at gmail.com

-- 
Ticket URL: <http://projects.scipy.org/scipy/scipy/ticket/349#comment:1>
SciPy <http://www.scipy.org/>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list