[Scipy-tickets] [SciPy] #366: Bug in arpack.py ValueError: need more than 0 values to unpack

SciPy scipy-tickets@scipy....
Thu May 31 03:34:35 CDT 2007


#366: Bug in arpack.py  ValueError: need more than 0 values to unpack
--------------------+-------------------------------------------------------
 Reporter:  nils    |        Owner:  somebody     
     Type:  defect  |       Status:  new          
 Priority:  normal  |    Milestone:  0.5.3 Release
Component:  Other   |      Version:  devel        
 Severity:  normal  |   Resolution:               
 Keywords:          |  
--------------------+-------------------------------------------------------
Comment (by nils):

 The problem is solved, but the test fails

 {{{
     w_a1,v_a1 = arpack.eigen_symmetric(A,k,which)
   File "/usr/lib64/python2.4/site-
 packages/scipy/sandbox/arpack/arpack.py", line 291, in eigen_symmetric
     raise NotImplementedError("generalized eigenproblem not supported
 yet")
 NotImplementedError: generalized eigenproblem not supported yet
 >>> A
 <362x362 sparse matrix of type '<type 'numpy.float64'>'
         with 5786 stored elements (space for 5786)
         in Compressed Sparse Column format>
 >>> k
 6
 >>> which
 'LA'
 }}}

 It's a standard eigenproblem. So I do not understand the message
 raise NotImplementedError("generalized eigenproblem not supported yet").

-- 
Ticket URL: <http://projects.scipy.org/scipy/scipy/ticket/366#comment:3>
SciPy <http://www.scipy.org/>
SciPy is open-source software for mathematics, science, and engineering.


More information about the Scipy-tickets mailing list